Can't connect to Roon on Orbi network

Core Machine (Operating system/System info/Roon build number)

Windows 10/Intel i7 8700k/Ver 1.7 (505)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Orbi RBK50/Netgear/Ethernet for Core (PC) and Wifi for remote (MacBook Pro)

Description Of Issue

In order to improve wifi connections in my house I upgraded to an Orbi system. Immediately noticed that I couldn’t connect to Roon on my MacBook Pro which I use to control the Core on my PC. A really quick search on the forums showed the fix of unchecking “Disable IGMP Proxying” in the Orbi settings, but it doesn’t seem to have solved the issue. Followed that up with a router reboot, a core reboot and even a reboot of my MacBook Pro but the issue remains. My remote sees the core and tries to connect, but continually fails. Help!

Maybe this thread might be userful?

I wish it was, but it’s not quite my case. I replaced my old router with the Orbi so it is connected to my modem and acting as the router, so I need to keep it in router mode, not AP mode.

I initially had significant problems with my Orbi Mesh Network. (Their support was terrible). I won’t go thru all of the problems but working with others I found that I could not plug my devices directly into the back of the Orbi devices. Once I inserted a unmanaged switch just after the Orbi unit and then connected my devices to the switch I was good. I never could get a answer from Orbi why I needed the switch to make things work.

Oh, that’s very interesting! I actually have a new unmanaged switch coming in tomorrow so I will see if that fixes the issue. I seem to always be under the impression that when I upgrade to new technology it will work “better.” That’s never quite the story.

Hi @Luke_Boyce,

I wonder if the WiFi vs Ethernet is being separated into two different subnets. It shouldn’t but not sure how exactly the RBK50 handles these kinds of connections.

I would try the unmanaged switch to see if it helps and if it doesn’t I would try plugging both the Core + Control via Ethernet or using them both on WiFi as a test.

So I did test both. I tried connecting the Core to the WiFi only and then tried to use the Control over WiFi and it gave me the same never-ending connection battle.

Then I tried plugging it back into the ethernet and opening the Control on my other PC which is also connected to the very same router via Ethernet. Same result: never-ending connection battle.

I’m really hoping the switch can save the day here, cause after that I’m kind of out of guesses. Which sucks because outside of this one issue the Orbi set-up has been excellent.

I’ll add that the thing that’s messing me up here is that the Controls all see the Core no problem. They see it immediately, they just refuse to connect to it, which leads me to believe that it is related to a setting in the Orbi network, but I can’t even begin to know what that would be. It’s gnawing at me.

I get that from time to time. I don’t have an Orbi but I have a Triband router and I have both 5g bands joined as one. Not sure if that is related or not.

Hi @Luke_Boyce,

Can you check to see if Roon is still allowed past your Windows Firewall? Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path. I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have.

I would also make sure that the network you are connecting to is set to “private” rather than public in Network Settings:


@noris, man, that did the trick!! I’m elated!!

I got the unmanaged switch today, which did not fix the issue, but adding the firewall exceptions and changing my network to “private” rather than “public” was the solution. I’m so grateful and happy to be enjoying my Controls again.

A million thanks!!


Hi @Luke_Boyce,

Awesome, glad to hear that the private/public setting was the solution!
Hope you have a continued enjoyable Roon experience :headphones:!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.