Can't connect to RoonServer running on Windows Server 2012 R2

I’ve installed Roon Server (v1.1 build 102) on my Windows Server Essentials 2012 R2 system. I’m running on an Ivy Bridge Core i3 processor, the system has 16GB of RAM. My media is stored on a hardware RAID6 setup - it shows up in Windows as a single drive. I have enabled the Desktop Experience feature and installed the Server Essentials Media Pack. The server runs, and the Roon app (v1.1 build 102) running on my desktop (Dell Inspiron 24 - Skylake Core i5, 8GB RAM) can see it, but can’t connect. I go from “Connecting…” to “Connection Failed” a few times, and then I just see “Last Seen n seconds ago.”

I tried creating firewall rules for RoonServer.exe to open everything incoming and outgoing with no change. I am connected via wired Ethernet through a Netgear Nighthawk X6 R8000 running the latest firmware (v1.0.3.4_1.1.2).

Other posts I’ve read regarding Server 2012 R2 suggest I should be working. Does anybody have tips to help me troubleshoot this?

Take care,

I have a working instance running 2012 R2 - I’m not a regular windows user so I’m sure there are much better and more secure solutions…I simply disabled windows firewall.

When I stop the firewall, my remote desktop session drops and I can’t reconnect until I reboot the server and the firewall restarts. Not sure what’s going on there.

Roon uses these ports: UDP 9003, TCP 9100-9200.

I was trying out Roon on a WHS 2011 system. Initially, I tried modifying the firewall rules associated with the roonserver.exe to add those specific ports. This didn’t help.

What turned out to be the solution was to create two new rules (one for the UPD port and one for the TCP port range) that were not tied to the roonserver executable. I.e. they were purely port rules (but I made them apply only for the local network).

This may be what you need for WSE 2012 R2…

I swapped the roonserver.exe based incoming and outgoing exceptions for generic ones for UDP:9003 and TCP:9001-9002. Same result. I can see the server, but I just get connection failed.

Dunno, just know it’s precisely for these reasons I hate fiddling with Windows. Wait till you try running Roon as a service not requiring a user login. :tired_face:

Is the network card set to private or public network? Make sure it’s private and disable firewall completely for private networks as your server is internal behind your router that does basic firewall duties.

That looks like it was the problem. The client was set to “Private” and the server was set to “Domain.” I opened the ports to “All” and got connected. Thanks!

1 Like