Can't Connect to Tidal


Is anyone other than me having trouble connecting to their Tidal account via Roon? I have been been using Tidal ever since I signed up for Roon, but tonight for some reason Roon lost its connection to Tidal. When I try to login via Tidal, I get an error message saying “Bad username or password,” but the same username and password are still working fine from Tidal’s app (on iOS) and on Tidal’s website.

My Roon Core is installed on a MacBook Air running OS 10.12.6, and I’m running the latest build of Roon (Version 1.3, build 262). I have a US Tidal HiFi account, but am physically in Japan (as I have been ever since signing up with both Roon and Tidal).

Any hints? Should I just wait until my morning and see if this has fixed itself?

Hi @StuartB ---- Thank you for the report and sharing your feedback with us!

Moving forward, I would recommend the following (in this order):

  1. Try power cycling the device hosting your Roon core

  2. Try deleting your TIDAL cache.

If either of those tips do not yield a positive result:

  1. With the application not running … would you mind going into the database on your Core and deleting this file:


If you are unable to locate the ‘tidal_account’ file:

  1. Confirm that your TIDAL account is still active, as suggested here.


Having the same problem. Cannot find the tidal_account file yet my Tidal account is working on everything else.

Same problem here - but intermittently. Tried deleting the account file etc. … keeps reoccurring (latest build 262). If I make the mistake the react to the error message, I have to retype my Tidal password. If I ignore it, it starts working again after a while.
Suggestion for improvement: Password should be retained.
Yes, Tidal works continuously fine everywhere else.

I had this yesterday. Signed out, signed back in and it worked again.

1 Like

Step 1) alone worked for me. I just rebooted the computer hosting my Roon Core and then was able to log back into Tidal from Roon. Embarrassed that I didn’t try this before, since rebooting has always been my primary problem solving technique (since the days of the Apple ][)…

Thanks very much for the quick help on a Sunday!

By the way, this has never happened before. I’ll report back if it becomes a regular issue.

1 Like

Hi @Ralph_Hunter ---- Thank you for chiming in and also for being proactive by checking for the “TIdal_Acoount” file in your “Core” folder :thumbsup:

A few weeks ago I had another user report a similar experience, which lead to the following:


Have you confirmed if you notice the same in regard to your TIDAL subscription?


Hi @mzbe ---- Thank you as well, for the insight. Very appreciated!

Moving forward, I see you had posted on similar thread, is this the same behavior you’ve reported, previously?

Furthermore, I see that I had replied to your post(s) and asked for some logs via a PM which I do not see a reply for. Please let me know if this is the same issue and we can pick up on the thread you had posted in originally.


I’m connected (according to Roon settings) but cannot play any Tidal content. I get a message saying “this track is currently unavailable on Tidal”, or an empty playlist. I flipped over to the Tidal app and everything is fine…

SOLVED. Restarting Core did the trick. Should always try that before typing…

Yes of course my Tidal account is working on this computer and several other devices.

Hi @Ralph_Hunter ---- Thank you confirming that for me.

The reason I had asked, is because the user (in the mentioned thread) reported that he could login to TIDAL via the desktop application/the Web UI (without issue) and also noticed that his Tidal_account (file) was not in the specified location.

Moving forward, can you please note the time when TIDAL fails to log in via Roon and use the instructions found here to send us a copy of your logs from the device hosting your core.


Roon folks— this isn’t an issue with one person’s cache folder or setup. It is with old albums and new albums. I use Roon so that I have integration with Tidal. I am done with Roon if you can’t get this right. Let me know.

By the way, the same tracks WORK on Sonos management application. This is YOUR issue Roon.

It fails everytime, like just now when I tried to login. It is not time specific.

Hi @Ralph_Hunter — If that is the case, then we should see traces of the failures in your logs. If you can send those over to me, I will get them into our queue for evaluation asap.


Here is the link to my logs.

1 Like

Thanks @Ralph_Hunter, confirming that the logs have been received!


Any update? Still not working.

Hi @Ralph_Hunter — Letting you know that I have contacted you via PM, with our findings based on the traces found in your logs and further data gathering questions as per our techs who conducted the evaluation.


having the same problem: was using TIDAL for many months, didn’t change anything, but for one week now TIDAL isn’t working with ROON, but still works with the iPAD app, can also log into the web site, shows my active Hifi subscription …