Can't determine if MQA is playing properly

I need advice on whether or not my system is set up and working properly. I am new to Tidal and Roon so please forgive me if this is an obvious situation. I can’t determine if the issue I think I have is how things are supposed to work or if there is a problem with my ultraRendu or DAC. I am still in my return period for both products and I need to get this figured out quickly.

My setup: Sonic Transorbiter 5 connected directly to the router of my 1GB network. My DAC is an iFi pro iDSD and it is plugged in to the ultraRendu via USB. The ultraRendu is connected to the network and is powered by the Sonore 7v power supply. My sequence for starting the iFi is to power it on and wait for it to completely boot up, then turn on the power supply for the ultraRendu.

I stream music via Roon and also use Tidal through Roon. In Roon, the ultraRendu is identified as the Bridge Device. Roon sees the iFi as “iFi (by AMR) iFi (by AMR) HD USB Audio” under Audio Device but says it is an unidentified device. In Roon the settings for the ultraRendu are: MQA Capabilities: No MQA support; Enable MQA Core Decoder set to yes.

My concern is that the iFi is MQA certified and yet I cannot seem to get the full streaming resolution when streaming MQA songs from Tidal through Roon. Tidal and Roon say the song is FLAC 48 kHz 24 bit, MQA 192kHz and yet it plays at only 96kHz, 24 bit. It happens on every Tidal track that indicates 192kHz. This is the signal path info I get from Roon. Is this how things are supposed to be or do I have a problem. Thanks in advance for any advice on this issue.


Yes this is the way the mqa core decoder works giving you a 96/24 or 88/24 stream. Any further decoding is done in your DAC provided it supports MQA. See this for more details.

As long as the Ifi is indicating it’s getting MQA your ok if not then their is a problem. The issue is your DAC cannot feedback to Roon as it’s connected to the microrendu not Roon directly. Roon can only get info from DACs that are directly connected to the core or another endpoint that’s running ROCK. I have a dragonfly Cobalt connected to a NuC that runs ROCK but it’s not my core and I can see the full signal path and final mqa unfold and rendering stage.

Very informative, thanks. That’s been my concern. The iFi has NEVER indicated any of the MQA tracks as MQA. It has only identified them as PCM 96. I will try to connect the iFi directly to the SonicTransporter via usb and see if that makes any difference.

Just hooked the iFi up to the SonicTransporter via usb. Same results. Here is the signal path. Does this indicate there is a problem with the iFi?

Two things:

  1. Make sure your iFi Pro iDSD firmware is 2.01 or later (current version is 2.08)
  2. If the firmware is new enough, try setting MQA Capabilities to “Decoder and Renderer” (note: not for other iFi products)

On my Nano that was connected to pi or my NuC settinngs in Roon where renderer only for the DAC. If your using the microrendu you might need to set it to no mqa support turn of any mqa processing on the Sonore and it should then pass it through to the DAC. Make sure DAC is on latest firmware that supports MQA.

I would try disabling Roon MQA decoding and see if your DAC takes care of decoding and rendering. I don’t have a bridge setup so can’t say for sure but I think you will need to adjust the settings for the bridge and the DAC.

Ultrarendu: no MQA and turn off MQA core decoding switch
iFi: set as MQA capable and select decoder and renderer option.

More problems. I discovered that the firmware is only v1.60 and needs to be a minimum of 2.01 for MQA capabilities. That’s the good news. I tried to install v2.01 from my MAC but I get an error message that the file is damaged or incomplete. When I tried to install again it said the upgrade was incomplete. I have been afraid to try to install v2.08 not knowing if v2.01 has to be installed first. Does anyone know if it is possible to upgrade from v1.6 directly to v2.08 without first installing v2.01? It seems I have received an old unit, v2.01 was released in Feb 2019, so I am just guessing, but my feeling is that this unit is from sometime in 2018 with such an old firmware version. I have opened a support ticket with iFi and am waiting to hear back from them. Thanks to everyone for all the valuable advice. I will report back once I hear from iFi. I am very tempted to return this and go in a different direction. Suggestions?

I don’t think they are incremental upgrades. You should be able to just install the latest version and not worry about others. I did when I got my Nano.

Tag @Jake_iFi

1 Like

SUCCESS! Special thanks to CrystalGipsy, Peter and Connor, the problem is solved. It was indeed the firmware version. I upgraded directly to v2.08 from 1.60 and that did the trick. Enjoying MQA at indicated streaming rates. Thanks to everyone for your help.

Now that the tech is squared away, can you hear an improvement?

I’m glad it works for you now. One question though - previously you experienced an upgrade error - what steps did you take to get rid of the error?

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.