Can't disable DSD to PCM conversion

Hi, folks. I’m running Roon 1.8 (build 831) on Synology NAS with the Client 1.8 (build 831) on my MacBook Pro.

The audio device is Chord Hugo2 bridged by Chord 2Go streamer.

All my DSD media is converted to PCM - see attached - and for the life of me I can’t figure out how to disable it. Hugo2 support DSD and I want to play my DSD files natively on it.

What am I missing?

Hi, it seems you have headroom management enabled for that device. If you want DSD playback, you need to disable all DSP.

1 Like

DSP Volume does not support DSD. The reason for this is that it is implemented on the endpoint device, and these generally do not have sufficient processing power to perform DSP operations on a native DSD stream.

1 Like

Regardless of processing power, it is not possible to perform DSP on DSD without first converting it to PCM.

That’s not quote correct. I can apply all sorts of DSP on DSD natively in Roon without converting to PCM. This includes Convolution for digital room correction, PEQ, volume leveling, headroom management, etc. It uses a lot of CPU resources, but it works as long as all of the processing is done on Core.

Edit: Example:

(Ignore the DoP, that’s just a limitation of the iFi ZEN Stream that I’m using as my endpoint)

Roon converts DSD to PCM, performs DSP and then converts back to DSD. The sigma-delta modulator does the PCM-to-DSD conversion.

1 Like

No. It is not. But it is converting to 64-bit DSD. This post explains this somewhat, but there may be other posts that explain more thoroughly. The main takeaway should be that Roon is NOT converting to PCM.

DSD is always 1 bit. “DSD64” means DSD at 64 times the sampling rate of CD, i.e. 44.1kH x 64 = 2.8 MHz. Roon seems to be using 64-bit floating point PCM for DSP.

Thanks @Marian_Trandafir and @David_Snyder. I have now turned all DSP attributes off - see attached. Sadly it didn’t help. DSD is still converting to PCM.

Please re-read @brian’s post. I’m pretty sure he knows what he’s talking about. Rather than getting lost in terminology, everyone here should know that Roon is perfectly capable of performing DSP processing on DSD without converting to/from PCM. The rest is semantics.

You need to go in to the settings for the Zone (Audio tab under Roon Settings) and disable “DSP Volume”.

Can you share the new signal path?

1 Like

Here is the new signal path, and in Zone settings (lower below) I do not see DSP Volume.

I still see DSP volume enabled. You have to go to “Device setup” and change that to “Device volume” or “Fixed volume”

Just checked. Device Volume is - and was - set.

There is no possibility to make Roon send DSD to the Chord until the Chord is setup to accept it.

On the 2Go not Roon but exactly that’s the issue at hand. RTFM: 2go-user-manual-V1.4.pdf

Point 7: DSD/Bit Perfect toggle needs to be On, will disable DSP Volume on the 2Go.

2 Likes

That did it! Thank you, everyone: @BlackJack, @David_Snyder and @Marian_Trandafir - for the quick response. I appreciate you very much.

5 Likes

Just be aware that the chord is immediately turning the DSD into pcm before processing the audio. Only the Dave does DSD native processing. So you might as well have Roon convert it to pcm

3 Likes

Wow, I had no idea. But since you mentioned it, @Rugby, I went ahead and looked, and yes, you are right. Rob Watts himself attests to it here.

I’m going to switch the conversion back to Roon then, I prefer it there rather than on the DAC.

Thanks for this important info.

2 Likes

No problem, xred. It is a common misconception, made more-so since the INPUTS of the DAC can accept native DSD.