Can't find Roon Core

Core Machine (Operating system/System info/Roon build number)

macOS Catalina 10.15.7 / 2017 iMac with 4.2 Ghz Quad Core i7 Processor

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Synology DS 1621 connected by Cat 6 cable to the iMac

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Roon End Points are (i) Meridian DSP 8000, (ii) Denon PMA 1500AE, (iii) Trinnov Altitude 16

Description Of Issue

The system has been working well for 18 months or so until a couple of days ago. Now, on the iMac which has Roon Core, I get a message saying ‘Choose your Roon Core’. I have rebooted the iMac,and the NAS but there’s no change. I still get the same message. Now it keeps saying ‘Looking for your Roon Core’. Roon had updated itself a few weeks ago, so the Roon is also up to date.

I’ve tried configure Roon OS devices on the network, but it just says, ‘searching for devices’.

Would like to know what I can do to fix the issue.


Did you choose your Core?

You’re not the first to be confused by this message.

You don’t have a Roon OS device. A Roon OS device is a Nucleus or a PC, usually a NUC, running ROCK.

Don’t try to find a Roon OS device. It won’t work. It will always keep searching without finding anything.

Hi @Havelock_Roche,

Can you share a screenshot of the Choose your Roon Core screen?

Dear Dylan… This is the screen I get. Like I’d said in my earlier mail, this was working for a year and a half with no glitches whatsoever. And no change or update has been made to the system in the recent past.

To give more detail, I was at the computer doing work and thought I’d put on some music. And the Roon screen was the regular one with Album art, last played song paused etc. But it showed my Meridian and Balcony audio zones but not the System one, which plays music on the computer. Normally that’s always visible cos I’m on that iMac and the core is on that too. So I exit Roon, and open it again. After which, this is the screen I get.

Thanks for that info.

Ha, at least you get that much. My ipad pro refuses to connect to the core and it is stuck in audio output via itself mode. I’ve deleted and reloaded the app 3 times and powerd off the ipad and also done a hard reboot. It refuses to connect to the core. My surface pro4 and mac book pro still seem to work but not my ipad.

Ha, I opened Ipeng, which in turn suggested i open Roon Remote, which in turn got me to open the squeezelite Icon, which in turn was the correct remote NOT my IPAD icon. It seems all my endpoints except my mac book pro connect via the squeezelite icon.
On the off chance this helps anyone else. Good luck

There are only two options that are available. You had mentioned the first one, ‘Find my Roon Core’ wouldn’t work, and it didn’t anyways.

The second option is Set up a Roon Core on this Mac. So I click ‘Use this Mac’. It takes me to the login screen and once I login, I get the message, ‘You’re already signed in’ (see attachment). To connect to the core, click ‘go back’. But when I do that, it goes back to the Choose your Roon core screen I had attached earlier.

Unathorize your Mac and reauth it again

Great that worked.

When I unauthorised it, it surprisingly reverted to the regular Roon screen. All the end points didn’t work though initially, so I rebooted the computer and powered down all the endpoints and powered them up again. And it’s working alright now.


1 Like

please check the solution box

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.