Cant get 831 working, database error [Resolved: Restored backup]

Hi there, have a nuci7 on ubuntu 20.04 that I upgraded to 831 tonight, software update took but the db restore failed. Continues to fail to restore my DB after uninstalling and reinstalling roon. Tried different backups multiple times but end result is always “there was an issues loading your database”.

Any ideas?

did it not migrate the database at the update process? or did you kill that while it was happening?

1 Like

The upgrade process went as expected but once the system refreshed/rebooted after 831 installed I got the error.

Wait for @support to have a say.

IMO, you’ve had what Roon calls ‘latent corruption’ for a while and the upgrade to a new Roon version uncovered that. Any Backup you have done while this corruption existed has, of course, been corrupted. You can’t find an un-corrupted Backup because the condition has existed long enough so that all the good Backups have been overlaid,

If that’s true in your case, it’s something that has always been a problem.

1 Like

I was able to successfully restore a different backup from last week. Suppose I dodged a bullet on this one.

Thanks for your help


If your other Backups really are corrupted, then you should delete them and start fresh. Glad it worked out for you. I was not so lucky, once. I now Backup to many different places and on different schedules.

Hey @Rob_Rodier

I’m happy to see that you navigated this snag successfully :pray:

We recommend creating a manual backup now so you have a reliable, restorable, backup on hand should you need it. You can do that by going to Settings>Backups>Backup Now>Backup


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.