Can't get HQPlayer to work

OK thanks for your help. I’ll keep fiddling around and hope I can get it to work.

John

I’ve fell at pretty much the first hurdle. lol

Should I expect to see either my Arcam SA30 amp, or Chord 2Go (both Roon endpoints) in the list of available output devices in HQPlayer?

This is all I see

HQPlayer doesn’t see Roon Ready devices on a network. It has its own network software known as Network Audio Adaptor (NAA). In order to send output from HQP over a network you need an endpoint that is running an NAA.

Cheers for the reply, a bit above my head. So HQPlayer is limited to endpoints that have NAA?
Is NAA something that can be added to an endpoint?

You can output over a USB connection from the computer running HQP to any device that can receive USB digital audio, but if you want to output over the network then HQP needs to see an NAA.

You can download the NAA program for Windows, Mac or Linux on the Signalyst website. Some devices such as ulraRendu, include an NAA app in their software. DietPi has an option to run an NAA on a Raspberry Pi.

There is a list of devices with built in NAA on the Signalyst website.

Thanks, will have a look

1 Like

“You can download the NAA program for Windows, Mac or Linux on the Signalyst website.”

They must be hiding it really well because I sure as hell can’t find it lol

Yes, HQPlayer is limited to endpoints with NAA, just like Roon is limited to RoonReady/Bridge endpoints.

NAA can be added to the endpoint by the endpoint manufacturer.

See the last button at bottom of the page here.

Hi,

Ok, I have installed HQPlayer, and the networkaudiod, but still having no luck actually playing anything on Roon

Here is what I see when networkaudiod is running

When I start HQPlayer desktop this is what I see in my settings, some examples below

Which setting should I use, is it one of the Networkadaptors given I don’t have NAA inbuilt on either my SA30 amp or Chord 2Go? If so what should I select as my Device?
If I ever get the settings correctly applied what exactly should I see in Roon? Does HQPlayer appear under Audio settings in Roon?

Sorry for all the stupid questions but I have next to zero knowledge of networking and how it all hangs together.

What device are you running the networkaudiod (NAA) program on ? If it is the same computer as HQPlayer then I have confused you.

The NAA program is intended to be run on a network device that is connected to your network and to your DAC, not on the same computer as HQPlayer.

Neither your amp or Chord have NAA built in, so you either have to get a network device that can run NAA or connect one of your amp or DAC directly to your computer.

See this article in the Roon Knowledge Base about setting up an HQ Player Zone in Roon.

The HQPlayer manual was unpacked into the HQPlayer directory when you installed HQPlayer. Have a read of it, particularly the sections relating to Backend and Audio Device.

In short:

  • if you want to send output from HQPlayer to a network device running NAA then choose NAA as Backend and you should see the device as a selection under Audio Device. If it is your only NAA device then it will be the only entry;

  • if you want to send output from HQPlayer to a DAC or other Audio Device which is directly connected to your computer by USB then choose ASIO as Backend and select the DAC or other device from the list of available Audio Devices. Note that your DAC may need to be on with the USB input selected for it to show up.

HQPlayer manual can be easily found from Window Start-menu. And also on Linux from the desktop Start-menu. On macOS it is in the DMG and one can copy it to some suitable place.

You could try asking manufacturers of the amp and Chord to add such feature to make it work. If there are no people asking for the feature, it is unlikely to appear by itself.

Thanks for info.

So I connected Hugo 2 DAC by USB to the Windows PC where the networkaudiod (NAA) program is running.
Then added HQPlayer from my laptop to Roon via Setup, and then enabled it. Selected HQPlayer as the Zone on Roon and played some music from Roon. Couldn’t get anything to play without stuttering badly, unless there is some other setting to fix this I guess it’s a network problem?

Thanks,

I’ll ask about this on the Arcam forum.

You don’t need the NAA running on your computer if you are connecting your DAC to the computer by USB. The NAA program is intended to be run on a network device, not the computer on which HQP is running. For example, you might run the NAA program on a Raspberry Pi which has an Ethernet input and a USB output to your DAC.

Stuttering can occur when the settings in HQPlayer exceed the computational power of your computer. You can either reduce the settings or use a more powerful computer. If your computer has an Nvidia graphics card you can also enable CUDA (use the greyed option) which offloads some of the processing to the graphics card.

What are the specs of the computer running HQPlayer ?

In the screenshots above the default output is set to source, which means that a PCM input will result in a PCM output and similarly for SDM (DSD). It is more usual to explicitly select PCM or DSD output. Upsampling to DSD is more computationally intensive than PCM.

You also have different filters selected for 1x and Nx which may or may not be intended. The 1x filters are used for 44.1 or 48 kHz source files and the Nx for 88.1 or 96 kHz and higher source files.

What upsampling rate are you using ? You usually want to send your DAC the highest sampling rate it can take as an input. In the case of the Chord Hugo 2 that is 768 kHz PCM or DSD 512 (use the 44.1 multiples unless you know the Hugo 2 has a 48 kHz DSD oscillator). It may be that those settings are too demanding for your computer, in which case you might reduce the maximum upsampling bit rate.

The choice of modulator and filter can also affect the computational intensity. In the DSD settings you have poly-sinc-xtr-lp-2s selected for 1x which is a relatively long filter. Depending on your computer power you might need to reduce the sampling rate to DSD 256 or 128 to use that filter.

Thanks, all sorted now. PCM at 768,

1 Like

2 posts were split to a new topic: Upsampling to Hugo 2

Linux novice here. Can someone help show me how to mount a NAS for use with HQPe? Thanks.

If you use HQPlayer OS, then you have a link at the bottom of the web interface where you can mount SMB share from a NAS. Should be relatively straightforward. It will be at /smb and you can scan that for the library.

Please be a little more explicit. I tried many types of paths in Share and it said “Success”. Now in the web interface Library Path I’ve tried different things as well and can’t find it.

For example “//someserver/someshare” and then username and password.