Can't get Roon to play on my MacBook Pro [Resolved]

I went away for 2 weeks and shut down my Intel-Rock and the rest of my network. I came home and started everything up. There was a system update to my Mac while I was away and sometime recently Roon updated to V1.4, but I have no idea if this has anything to do with my problem. Rock is working and appears in network scans. My MacBook Air works fine with Rock/Roon and appears in network scans. iPhones, iPad and Sonos work fine with Roon when controlled by one of the devices on the Roon network. The MacBookPro that I use most seems not to be able to start up Roon. It just spins its wheels and eventually Roon crashes. Rock not only appears as a shared device on my MBP, I can play Roon selections on the MBP by controlling it with my MacBookAir or iPhone. This suggests everything is on the same network and is logged in. When I start Roon on my MBP it comes up with a page that asks me to choose my core (see attached). It never did this before. I have tried a bunch of different suggestions found in the forum but nothing seems to work. Almost seems like I need to uninstall Roon and its library files from this machine and do a clean reinstall. That’s pretty drastic so before I do that I thought I’d ask for help.

Have you purchased more than one Roon license? You appear to be trying to use simultaneously both ROCK and MacBook Pro as Roon cores.



I am not trying to do that. I don’t want my MBP to be a Roon core! That’s how Roon comes up even though I didn’t ask it to. What I can’t get it to do is offer me the opportunity to select my Rock as core. When I left home 2 weeks ago my cute little Nuc Rock managed everything perfectly. I greatly fear Apple has messed up my configuration or else the Roon app got glitched but it’s nothing I did.

When Roon on the Mac comes up and does not see a core it shows that screen. It does seem a little odd. I am wondering if you tried rebooting the MBP? A re-install is not painful.

I have rebooted to no effect. If I click on "why can’t I see my remote libraries I get the attached screen. If I fill in the IP address of the Rock, nothing happens and Roon crashes.

I’m thinking a reinstall is in order. I know how to delete the app. There are three Roon folders in the library: RAAT server, Roon and Rood Mounts. Should I delete them all? That should give me a clean start.

Hi @Bruce_Chassy ---- Thank you for the report and sharing this feedback with us. The insight is appreciated.

Moving forward, do you have the MBP setup as a RoonBridge by chance?

“Rock not only appears as a shared device on my MBP, I can play Roon selections on the MBP by controlling it with my MacBookAir or iPhone.”


Problem solved! I totally unintentionally solved the problem. I was having some problems with my NAS disk and in the process of updating firmware I bricked my system. I had to do a network reinstall of Mac OS X 13.2. Just now when I got Eric’s message I launched Roon again. I got a slightly modified page when I launched Roon (see below). It offered me the opportunity to select a different core and the core it offered was my Rock/Nuc. I selected it and it immediately returned to my former and desired configuration. Roon is now working the way it always did. I suspect updating to v13.2 messed up something in my networking firmware/software that had nothing to do with Roon. The odd Roon behavior was probably due to the fact that it couldn’t really connect to the Rock/Nuc even though it showed the server and said I was logged in… or something…

This topic was automatically closed after 26 hours. New replies are no longer allowed.