Can't get Roon to work properly

I am just trying to set up a Roon trial.

I have installed the Core on my Desktop PC (Windows 10 X64). Remote connections are set to be accepted on the Desktop.

I installed the program on my Lenovo Windows Laptop X64 (Windows 10 X64)). It cannot find the Core.

On my desktop the Oppo 205 appears on the Network but not on my Laptop’s Network.

I have tried to configure the ROON OS Devices but that doesn’t work.

Windows Firewalls and Kaspersky seem to be o.k. although given the nature of those beasts I am not 100% confident.

So far, color me unimpressed. However, I have always considered a company’s ability to handle situations where things don’t work to be a true test of its quality. Now is your chance to prove it.

Hopefully you can help.

(An extremely frustrated) Jim Ridgway

If you are certain your devices are on the same network, disable both of these for a moment.
(Oh, how glad i am to have left the Win-world! :joy: )

I disabled them (I think–The laptop won’t give me a clear answer as to the windows firewall).

I tried finding the Roon Core but no luck.

The Desktop will not appear on the Network in the Laptop.


Can you see the laptop from the desktop in Windows Explorer?

Sorry but I can’t see it.

Hi Jim,

Can you describe your network, including the brand and models of all routers and switches and what connections are Ethernet/WiFi ?

It is 3:23 a.m. my time and my brain is fried so I am going to bed now.

However, briefly:

Desktop (Roon Core) has a hardwired ethernet connection.

Laptop (To be used as the remote) is wireless only.

There are no switches.

Router is Actiontec V1000H.


1 Like

Possible culprits;

  1. Windows firewall still blocking.
  2. Antivir doing the same
  3. Router provides guest access for WLaN (You’re on two different subnets)

A. Get your ipadresses from each win computer. (Command IpConfig) Same first three digits? Like 192.168.1.nnn ?
B. Please get a cable and connect the laptop physically to the router. Check ipadresses again, report back?

Hey @Jim_Ridgway — Thank you for reaching out to us, and apologies for the difficulties here.

It definitely sounds like there may be some networking difficulties at play here, but I’m confident that we can troubleshoot this together.

On my desktop the Oppo 205 appears on the Network but not on my Laptop’s Network.

Sorry but I can’t see it.

Based on these two comments, it sounds like the laptop may be on a different IP range, or is perhaps connected to a guest network since it can’t see these other devices on the network. You can use a network scanning application such as Fing to take a look at the devices on your network which should give us some additional insight into what may be occurring here.

I’d also like to recommend confirming that the Kaspersky and any active firewalls are disabled on both the Core machine and the laptop remote. After making sure that it’s disabled on both do you notice any change?

I’d also like to recommend a test that should give us some more information about what may be happening. If you have an Android or iOS mobile device try installing the Roon Remote application and connecting to the Core. If you’re able to connect from one of these remote devices then we know that this issue is specific to your laptop. If it’s not able to connect that tells us that the issue may be something on the Core machine (firewall, antivirus, etc.) or an issue with the network.

Kind regards,

1 Like


ip addresses are:

A. Desktop

IPv4 Address
Subnet Mask
Default Gateway

Ethernet adapter Ethernet:

Media State…: Media disconnected

B. Laptop

IPv4 Address
Subnet Mask
Default Gateway

Wireless LAN Adapter Local Area Connection*3:

Media State…: Media disconnected

Same for Local Area Connection*4 and Ethernet Adapter

I believe my Local Area Connection is 4

As far as I can tell, there is no ethernet port on the laptop so I can’t easily connect the laptop physically to the router.

It does look like #3 of your “possible culprits”.

I will try to reply to Dylan’s email shortly.




I could not connect with my (Android) phone.

I am reasonably certain that I disabled all the firewall and Kaspersky crap (but it was after 3:00 a.m.). There was no change.

I installed Fing on my phone.



Dylan and Michael,

I just realized that I have a network extender if that is of any relevance.


Yup, seems likely. Can you log in to the Router and check configuration for WLAN?
Make sure it is in NAT mode, not Bridge. And if you have a Guest-mode, turn it off…

1 Like


I talked to the internet provider (Sasktel) and they checked my modem settings and the router is in NAT mode.


1 Like

It still does not work.


Still peculiar if you are getting a completetely different IPaddress from the WLAN connection (172.x.x.x)
You are 100% sure you are connected toyoir own WLAN? (Sorry, had to ask!)

Sorry Jim, when looking at your earlier post i almost seems your laptop is connected on 3G/4G?
What make and model is it?

When I log into the router, it looks like all the devices are there. These are:

TLR160 [ethernet port 2] which must be the desktop
Android-9480999 which must be the android phone
Unknown which must be the Laptop because I checked the address at the laptop’s command prompt and
the address ( on the router and they match.


Model is a Lenovo IdeaPad Yoga 13
Manufacture date is13/02/02

Have a look at the DHCP settings, to figure out why it is handing out IP-addresses from a different range on the WLAN (in the router settings, that is!)