Can't install because I get "Network Error: Please check your internet connection." [Resolved: was bad etc/hosts]

Core Machine

Windows 10
HP 750-170se
Intel i7-6700k 4.00 ghz
16 gb RAM

Network Details

Netgear X6 R800, Cat 8 ethernet cable, Verizon Fios modem

Audio Devices


Description of Issue

Can’t login when trying to install the Roon Core, etc. on my desktop PC, which will be the server. I also can’t login online from that same computer, but I CAN login from my laptop on WiFi on the same network (where I’m typing now). I’ve

  • power-cycled the Fios modem and the Netgear router twice, and rebooted the PC itself twice

  • changed the DNS to Cloudflare (primary) and (secondary) as per some other suggestions for this problem in the Community

  • tried turning off Windows Defender’s firewall and virus protection separately and together, to no avail; no other antivirus or antimalware on the machine

I’m now at a loss. What else should I try?

Hi @Tim_McCoy1, and welcome to the Roon forum. Sorry you’ve had to post for support so early. I’m not support, but I’ll try to help while you’re waiting for them. First question, do you get a reason why you can’t login by either method?

Thanks for the help!

When I’m in the app itself, I get the error referenced in the title to the OP: “Network error. Please check your internet connection.” If I’m in Chrome or Edge, I get “There was an error retrieving your account information. Please check your connection and try again.”

DOH! Sorry, could have read that.

Presumably you can browse the Internet on the windows pc? Do make sure you refresh the page, F5, to make sure it’s not cached. The obvious answer is there’s an issue with the wired Ethernet. CAT 9 cables aren’t a thing BTW, but I’d recommend a good old fashioned CAT5 cable with your router.

Yes, sorry, it is a Cat 8 cable–just mis-remembered the number. My download speed tripled when I moved from a Cat 7 to a Cat 8 cable, so there’s no way I’m going back to a Cat 5. :wink:

Yes, I refreshed the page a number of times, and that didn’t work. That wouldn’t help in the app anyway, right?

It doesn’t work on WiFi on that desktop PC either, which after just unplugging that Cat 8 cable and refreshing the page, yielded the same error as before.

I’ve had a couple of trials of Roon on this same desktop PC before (version 1.6, I believe, was the last one) and never had any problems, so I’m stumped.

Though I’d add a log as per the Support instructions from when I tried to login to the app this morning:

Still not official support but:

05/12 11:13:09 Debug: [base/updater] Checking for updates:<omitted data>
05/12 11:13:11 Debug: [appupdater] Update failed
05/12 11:13:11 Warn: [appupdater] Couldn't connect to update server: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it

Do you run any addblocker software or something or did you manipulate your hosts file manually for some reason? I’m pretty sure that a DNS lookup for shouldn’t resolve to Maybe other similar redirects occur for (hosted most likely by Google Cloud services; your machine is possibly blocking some Google domains). This is also the likely reason why you also can’t login from the browser on that machine.

1 Like

Hey @Tim_McCoy1,

Welcome to the Roon community :wave:

I’m sorry to hear about the trouble you’ve ran into and thank you for letting us know. It looks like Roon subscribers have already jumped in to help (thanks @BlackJack and @killdozer :pray:!).

I was wondering, could you please disable your firewall and antivirus on this machine, just as a test? Does it work then?

Thanks :pray:

I’d already tried this (third bullet point in the original post) but just tried again (i.e., I turned off Virus and Threat Protection and the 3 firewall options in Defender: public, private, and domain) and still couldn’t login into the app or to my online account.


No, I got rid of my Chrome ad blocker extension a couple of years ago at least, maybe longer.

And: not sure what the “hosts” file is, so don’t think I would have manipulated it. Where is that located?

Got it: it was a bad hosts file. Found out where it was located on this thread

and found it with the wrong redirection. Must have been the previous PC owner had a pirated copy or something.

Thanks for everyone’s help!


Hey @Tim_McCoy1,

Thank you for sharing that :pray: and, more than that, thank you for your dedication in finding a solution. I’m sorry we didn’t get a chance to help more…

Thanks for finding it :slightly_smiling_face:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.