Can't install ROCK - "Failed to load ldlinux.c32" [Solved: download new image]


I am trying to install ROCK on NUC7i5BNH. I was able to flash latest BIOS (63), and update settings. However, when I try to boot from the flash drive with the ROCK image, I consistently get the ldlinux.c32 error. I’ve tried formatting FAT and FAT32 using Etcher from 2 different PCs and two different USB drives. I really want this to work, but need an image I can install. Please help!

1 Like

Hi, @Brett_Kerbel, sorry to hear about your troubles. Are you getting “failed to load ldlinux.c32” error?



Hi Ivan,

I’ll chime in as I have the same issue. Brand new NUC7I7BNH, updated BIOS to version 0063 (4/13/2018) and adjusted settings in BIOS. Lates ROCK image cannot boot and gives me an error reading
“Failed to load ldlinux.c32”

Any thoughts? What am I doing wrong? @support


Yes - this is the exact error I’m seeing. @support

Turn off EFI boot and turn on legacy boot… Let me know if that works

Already done - I followed the instructions to turn off UEFI boot, enable Legacy, enable USB Boot, SSD drive is listed first. The only other thing in boot is that optical drive boot is also enabled? I wouldn’t think this is a problem.

I have updated a new NUC7i5BNH to BIOS version 00063 successfully. BIOS changes were made to use legacy boot from M.2, then HDD, followed by USB. Network boot was turned off. I then used Etcher (version 1.4.4) on my Mac to create the ROCK image on on several USB sticks of varying sizes (all > 1GB).

When trying to boot to the USB image on the NUC, the error message “Failed to load ldlinux.c32” always appears. That file can be found on the ROONRESET volume in the “boot” folder.

Any ideas of where to proceed next?


UPDATE: I successfully installed Linux Mint 18.3 using the same NUC BIOS settings. Etcher was used to create the bootable image on a USB stick (on MacOS High Sierra).

Is there a problem with the Roon ROCK image?

Hi @James_Silver ----- Thank you for the report and more importantly, thank you for your patience here. The feedback is appreciated!

Continuing forward, we have many users who are installing ROCK without issue so I am inclined to believe that the ROCK image is functioning as expected. However, I did do some research on the mentioned error you are receiving (i.e “Failed to load ldlinux.c32”) and it appears this is related to the how the USB disk is formatted. I read a few posts on other forums where users had changed the formatting from “FAT 32” to"FAT” and that fixed the issue.


Unfortunately that did not work for me. I have tried performing this task with various Windows, Mac and Linux computers to no avail. I have used a variety of USB sticks from 6 different manufacturers. Time to give up and sell the NUC.

I’ve not tried bios 63 yet… It was very recently released. I’ll grab and try this afternoon. Try 62?

Hi Danny, I reverted to BIOS version 0062 to no avail. Still getting the same error message.

Thx for your help!

Hi Danny,
I have been trying previous BIOS versions as far back as the current NUC would allow, but to no avail. I have brought the NUC to work where I’ll have the resident Linux guru have a look. I wonder if GRUB will have to be copied onto the USB stick after Etcher creates the image.
Just to ensure the NUC is functioning correctly, I successfully installed Mint on it. Run fine.

Thanks for your help!

I’m having same issue. Just tried with BIOS V62 and still no luck. Failed to load ldlinux.c32

Hi since I saw several uses mentioning that the usb Image for ROCK was apparently not working I tried it myself this morning. I can confirm that you get the error during bootup that a file is missing. An older image I still have here works fine. The error message from syslinux is

Failed to load ldlinux.c32

I just saw that this is already tracked in the support channel, sorry for the noise…

@Maru I merged your post with the existing thread to keep all of these together.

Is it possible to install the older image and then update? Where can we download the older image?

Same issued I am having with my new NUC7i7BNF–although in my case the BIOS is not the supported Intel BIOS…so perhaps there is hope for me when this gets sorted out.

can you guys attempt to re-download and try again?

Version 00000157 appears to be installing correctly on the NUC7i5BNH with BIOS version 000063.