Can't install ROCK - "Failed to load ldlinux.c32" [Solved: download new image]

Hi @James_Silver ----- Thank you for the report and more importantly, thank you for your patience here. The feedback is appreciated!

Continuing forward, we have many users who are installing ROCK without issue so I am inclined to believe that the ROCK image is functioning as expected. However, I did do some research on the mentioned error you are receiving (i.e “Failed to load ldlinux.c32”) and it appears this is related to the how the USB disk is formatted. I read a few posts on other forums where users had changed the formatting from “FAT 32” to"FAT” and that fixed the issue.

-Eric

Unfortunately that did not work for me. I have tried performing this task with various Windows, Mac and Linux computers to no avail. I have used a variety of USB sticks from 6 different manufacturers. Time to give up and sell the NUC.

I’ve not tried bios 63 yet… It was very recently released. I’ll grab and try this afternoon. Try 62?

Hi Danny, I reverted to BIOS version 0062 to no avail. Still getting the same error message.

Thx for your help!
Andreas

Hi Danny,
I have been trying previous BIOS versions as far back as the current NUC would allow, but to no avail. I have brought the NUC to work where I’ll have the resident Linux guru have a look. I wonder if GRUB will have to be copied onto the USB stick after Etcher creates the image.
Just to ensure the NUC is functioning correctly, I successfully installed Mint on it. Run fine.

Thanks for your help!
JD

I’m having same issue. Just tried with BIOS V62 and still no luck. Failed to load ldlinux.c32

Hi since I saw several uses mentioning that the usb Image for ROCK was apparently not working I tried it myself this morning. I can confirm that you get the error during bootup that a file is missing. An older image I still have here works fine. The error message from syslinux is

Failed to load ldlinux.c32

I just saw that this is already tracked in the support channel, sorry for the noise…

@Maru I merged your post with the existing thread to keep all of these together.

Is it possible to install the older image and then update? Where can we download the older image?

Same issued I am having with my new NUC7i7BNF–although in my case the BIOS is not the supported Intel BIOS…so perhaps there is hope for me when this gets sorted out.

can you guys attempt to re-download and try again?

Version 00000157 appears to be installing correctly on the NUC7i5BNH with BIOS version 000063.

Hi @danny the new version of the image works fine, thanks.

Looks like the new version is working. “RoonOS install is complete!”. Now I just need to get through the rest of the steps

Hi @danny, the updated version of the ROCK installer works fine with BIOS version 0063 on my NUC7i7BNH. Thanks!

A post was split to a new topic: Having troubles updating ROCK to 1.5

Hi,

I just purchased a fanless NUC7i7BNF from simply nuc. Unfortunately, they use an American Megatrends BIOS rather than the Intel BIOS. I am still trying to get them to help me, but they tell me that I can’t replace the installed BIOS with the Intel BIOS because they swapped out some parts–I am a bit peeved, because their documentation points you to the Intel documentation about updating BIOS and I didn’t know they substituted the BIOS prior to purchase. I did manage to install Ubuntu, but I can’t mange to install ROCK. When I try to boot the box with the USB, I get the following message:

  "failed to load ldlinux.c32_
   boot failed: please change disks and press a key to continue"

I have tried several different USB sticks, I tried using etcher on both macOS and Windows10. I even used command line in linux to format one of the usb sticks.

Any suggestions would be welcome.

I have never worked with Linux before, and I may not be geeky enough to be successful, so giving up for now. I may default to running it as Ubuntu and installing Roon Server. I will still end up successfully replacing my old larger windows HTPC, but I hate to install Roon server, switch over and dismantle my windows server until I give up on ROCK (or MOCK as the case may be).

Mike

and there are two partitions on the USB install drive after burning:

ROON RESET, with a boot folder full of .c32 files including ldlinux.c32 and a bootfs.img.gz file. Also mbr.bin and lost+found

CUSTOM ROON, with roon.tar.bz2, identity, .fseventsd, and .Spotlight-V100

Why the hell are they changing the BIOS?

To be honest, it may be possible to get it to work, but there may be more aggravation in the future. I would return it for a refund or get them to exchange it for a fresh unit with original BIOS and no swapped parts. Better to have the original hardware as opposed to some “value added” add-ons.

Nothing on their site suggests they ship with AMI BIOS so if they refuse to take it back then it’s time to talk to your credit card company about a chargeback.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.