Can't launch roon server since update to 1.8

Core Machine (Operating system/System info/Roon build number)

OSX Catalina ver 10.15.7 (19H524)
MacBook Pro (13-inch, Mid 2012)
Intel HD Graphics 4000 1536 MB
Roon 1.8 latest

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet. Wired. Cisco routers.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

All audio devices are Meridian except for one old logitech radio.

Description Of Issue

Roon server will not start properly. The roon drop down menu on the icon bar at the top of the screen shows Roon status: Started then switch to Error. This is continues cycle. Nothing else is working.

Did nothing other than say yes to the upgrade message the day after launch. Has not worked since.

Any help would be appreciated.

Reboot everything you possibly can.

When you say Roon server do you mean RoonServer or are you just calling Roon on the Core machine the server?

If you are running RoonServer, try running Roon. Just as a test to see what happens.

Running roonserver. Yep already tried the reboot. No luck.

Then try this -

Ok, tried it and Roon does run. No library though.

Do you have a Roon library backup?

Nevertheless, tagging @support to help with RoonServer.

thank you for the help. I was not expecting the library to be there but via one album I confirmed I can play music and use an iOS app. So, that is something.

I am a bit nervous mucking around too much as I don’t know much about the data/dirs etc/ Also, as you assumed I would prefer to get roonserver running.

My prior roonserver installation had backup configured and the last timestamp is feb7 which is close enough. I made a copy of the backup dir and also the /library/roonserver dir just in case.

Thanks for the tag and help.

1 Like

Bump. This is dissapointing.
Now more than 30 days of not being able to play music.
Any chance for a response?

I decided there is no support coming so I better just reinstall from fresh.It would have been better to work with the roon team to uncover the reason for the failed upgrade as it might lead to root cause but it seems they have their hands full.

I backed up all my /library and /applications roon directories just in case, cleaning out and reinstalling a fresh install of roonserver. I then imported a backup and I was up and running again with some loss of activity due to the date of the backup.

So, resolved.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.