Can't link Tidal account

Core Machine (Operating system/System info/Roon build number)

Linux jj 4.17.0-0.bpo.3-amd64 #1 SMP Debian 4.17.17-1~bpo9+1 (2018-08-27) x86_64 GNU/Linux
dave@jj ➜ ~ cat /etc/issue
Debian GNU/Linux 9 \n \l
1.7 build 571

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Chromecast audio and chromecast

Description Of Issue

I can’t link my Tidal account. I’ve tried from both my laptop and android device. I get the prompt in my web browser to login to Tidal. I enter my credentials. Then I see a prompt to return to the Roon app. hit OK. Roon app takes over the screen but still shows the Login/Free Trial options.


Not sure what you are describing, but the way to use Tidal in Roon is thru Settings==>Services, not by logging onto Tidal thru a web browser.

Maybe it’s changed since you’ve done it, but now Roon uses OAuth which is a standard way of linking accounts

Settings=> Services => Tidal => Login opens a web browser to the Tidal site. Again, all standard stuff…

Ah, OK. I haven’t used Tidal since the logon changed.

Sorry for the noise. :neutral_face:

I have a few days left on my Tidal sub, but I had logged off inside Roon.

For yuks I logged onto Tidal again, using the new way, without any problem.

Maybe it’s your browser? I use Firefox.

Hi @David_Badia,

Do you have any firewalls active on your Core machine?
Is the behavior the same if you try to temporarily disable the firewall?

Thanks for checking that out. Good to know that it’s working for you. I’m using FF as well. Tried chrome too. Must be something on my end

That was the problem. I didn’t have a firewall, but I just moved and my default gateway was bad on the linux server so all DNS lookups were failing. Fixed that, went through the process again, and it worked. Thanks!

1 Like

Thanks for letting us know @David_Badia, glad to hear the suggestions helped!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.