Can't log in Qobuz [resolved]

Sonicwall is a hardware firewall. Settings haven’t changed since months. All switches are unmanaged. The switch where MU1 is connected (between the firewall and MU1) is a Zyxel GS1200-5 IPTV 5 Port, especially dedicated for streaming devices.
As mentioned, everything worked well during the past months. Early September, my Quobuz yearly subscription was automatically renewed; shortly after that, for some days, the same problem as now occurred, that I wasn’t able to connect to Qobuz from Roon (directly Quobuz worked always). After few days it worked well. Now, again it’s not working anymore. As no hardware or software configuration has been changed, I believe that the problem lies at Roon and/or Qobuz.

Hi @Thomas_Baumer,

I am going to enable diagnostics and take a look at the logs. I’ll review my findings with you shortly.

Thank you kindly for getting him some guidance!


Here’s something interesting in the logging. To me, it’s either a literal explanation of the problem or a perceived problem as a result of some networking practice or anomaly. This occurs during account verification.

09/20 15:36:56 Warn: [qobuz] [http] error result from http request: {"status":"error","code":403,"message":"Proxies and VPNs not allowed"}

and this is the other error that might imply that the remote can see the core but not the storage. Just a guess but more information might shed light on this (see questions below):

09/20 19:05:51 Error: [library/mobilesync]     unexpected error: System.ArgumentNullException: Value cannot be null. (Parameter 'collection')

Which device are you using as your remote? Does this happen on all instances of remote (smartphone/tablet/computer)?


Thanks for your time and suggestions. Indeed, the problem occurs on all my devices: 3 iPhones, and one on my Computer (Windows 10) which all give me an “unexpected error” when I try to sign from Roon into Qobuz. Fortunately I still can connect Tidal…
If you believe that some data might be blocked by my firewall, let me know and I’ll check with their support.
Let me know if I should leave my Roon Core switched on for your checkups.
I don’t think that the Grimm MU1 (hardware or software configuration) could be involved into this problem, however if you wish me to check something specific or to organize a remote session with the Grimm people, let me know.

You are most welcome, @Thomas_Baumer. Always happy to help.

I am not sure that the firewall is blocking but maybe masking? We use a special method of authenticating the account and I believe the message about Proxies and VPNs is coming directly from It’s very possible that they changed something on their side.

I think the second error is just a matter of syncing anything Qobuz related failing as a result of the authentication error.

I’m not sure exactly what you’d ask them but you might let them know we use an API to authenticate and are getting the ```
[http] error result from http request: {“status”:“error”,“code”:403,“message”:“Proxies and VPNs not allowed”} message in the logging. That might be enough to guide them towards a fix.

If you can’t get it fixed by talking to them with this additional information, please let me know. I will gladly escalate if needed.


Thanks! In case also other Roon users have this problem, maybe it’s best that you contact Qobuz? Or should I do so, by copying your info from before?

It sounds like you have a highly specialized setup that may be preventing the API from authenticating you and Qobuz is denying the request. Being in the forums every day this isn’t something I’ve seen.

Please do check with Grimm to see what might be done to remedy this. I will escalate beyond myself if needed but am fairly confident with my log findings being relevant to your unique setup.

Hi Wes, thanks for your suggestions. As Grimm didn’t have updates this month yet and the problem (signing in from Roon into Qobuz) occurred only in September, I guess the reason of the issue must lie either at Roon or Qobuz. However, it’s always good to keep Grimm informed, they are interested into all details in order to prevent from any trouble. So, if possible, please provide me with all details you observed, I’ll copy and forward them to Guido Tent (leading engineer at Grimm Audio). Or contact him directly - please mention my name, as we know each other. However, please still try to check within Roon but mainly also with Qobuz if the reason might be there…

I might be in a completely different Forrest here… But, Qobuz seem to block any sort of VPN while using their services. I’ve been unable to play within the Qobuz app if mine is on. It’s just something I’ve experienced myself as I’ve gotten that same exact wording from them. It can be seen if you try to login to their site.

I don’t have VPN. Still can’t log into Qobuz from Roon… When trying to log in, it always gives the error message (in German): “Ein unerwarteter Fehler ist aufgetreten. Bitte prüfe die Daten deines Benutzerkontos. UnexpectedError.” However, my data are definitely correct as I can log into Qobuz directly on my iPhone or Computer, it worked before and I didn’t change anything. Should I try to change my PW or username within Qobuz? However, as the problem only occurs when using Roon, it most probably has to do something with Roon or Grimm’s MU1 - but as Grimm didn’t change anything neither and it worked before, it’s indeed strange…

I did a reset of my password within Qobuz. I still can’t login within Roon into Qobuz. Same problem as past days. Please give me all needed details I can copy and forward to Grimm, or do it from your side if possible. I really wish to soon login into Qobuz again!

Ok, first off. My apologies as I had misread something here. Contacting Grimm certainly won’t help.

The error we are getting is a direct response from our calling out to Qobuz to create a connection to Roon. It’s Qobuz telling us that "“Proxies and VPNs not allowed” which is far more specific than the error number cited (404). Before you go down the road of trying to engage Sonicwall or your ISP, please try these steps.

  1. Quit Roon (or RoonServer)
  2. Find and open your Roon or RoonServer folder
  3. Locate and delete only the cache folder (Roon/Cache)
  4. Restart Roon

This was a fix listed for a slightly similar issue with Tidal. If it doesn’t do the trick I have to assume that there’s something with Sonicwall, your modem, or your ISP that is causing the issue.

Please let me know.


I executed your suggested steps but unfortunately, it’s still not working. I’m also in contact with Qobuz and they’re also looking. I checked my configuration and my Grimm MU1 with Roon is not behind the Sonicwall-Firewall: only my computers are behind the Sonicwall. So, Grimm/Roon is directly behind the Swisscom Router and the (unmanaged) Switch as described. I rebooted also the Swisscom router today. I’ll continue trying and will also contact my ISP (Swisscom). If you have any further suggestions, please let me know!

I’m in contact with the Qobuz support, and they suppose it might have to do something with my Roon-IP address which might somehow be blocked. They say the problem should be solved within a few hours. I’ll kep you informed.

1 Like

Good news: the problem is solved, I can again log in. Obviously the access from my Roon core to Qobuz was blocked…
Thanks for your helping anyway, I’m happy all works again.
Best regards, Thomas

1 Like

I had never heard of this happening before. I am so very pleased that it’s resolved and you’re back to your music.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.