Can't log into TIDAL (Nucleus - Build 528)

Just updated Nucleus to the new build 528. All my Tidal music is missing. Roon can’t login to Tidal. Went to settings > services and entered Tidal credentials. Error message: there was an unexpected error, please check your account details. (Missingmethod)
These credentials work fine logging directly into Tidal from a browser.

I tried rebooting Nucleus and my router and my iPad. No dice. Suggestions?

Hi @Robert_Crawford,

Thanks for the report. Can I please ask that you let me know:

  1. What is your network setup like? Can you list the model manufacturer of your networking gear and how the Nucleus is connected?

  2. Can you try logging in to TIDAL once more and note the exact local time + date you attempt to do this and receive the error? Once I have this timestamp, I can enable diagnostics mode and take a look in logs for any further clues.


Hi Noris:

  1. Info for my network and core machine:

Windows 10 Home; 64 bit
Verizon Fios G3100 Home Router (Gigabyte service)
Netgear GS108 Gigabit Switch
Roon Nucleus Serial #94C6911CFD7A
Roon Version: 1.7 (build 528)
RoonOS Version: Version 1.0 (build 186)
Vendor Version: 1.0 (build 12)

Nucleus connect via Ethernet to switch

  1. Tidal login attempt @ 12:05 PM 3/12/2020
    What happened just now from my PC > Roon > Services > Tidal login
    was very different than last night using my iPad Pro. From my PC, Roon went to what appeared to be the Tidal software, indicated that I successfully logged in but my browser did not return me to Roon. I manually went back to Roon and it said Tidal was not configured. I exited Roon and shut down Nucleus, repowered up and tried again @12:14 . This time I had a prompt from my browser to allow it to return to Roon and everything now appears configured and working. My experience over the last month or so is that I occasionally have lost access to Tidal via Roon and resolved it by simply restarting Nucleus. This time was much more challenging and required a visit to @Support. Hopefully things are now stable.
    Robert Crawford

Hi @Robert_Crawford,

Glad to hear that the additional reboot of your Nucleus sorted this issue out. Logging into TIDAL is not a process you should often encounter, so I am hopeful that the latest reboot + relogin has resolved the issues on your end. If you have any further difficulties though, feel free to let us know and we can take another look. Thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.