Can't login into TIDAL after update to build 610

Core Machine (Operating system/System info/Roon build number)

Synology DS1819+, Roon build 610

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Asus router, Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

After update to 610 I was greeted with a red box saying TIDAL login failed. Retry didn’t help. So, I went to settings, logged out of TIDAL and tried to login again. Got a box with a blue login button, pressed it. My default browser opened (Firefox 79.0, Windows 10 64bit). Logged in in the browser, got a message “You’ve successfully connected your TIDAL account.” Then Firefox prompted me to open a link in an external application with a “launch application” box.
So, I clicked “Open link” and nothing happened. In the Roon Windows app I still have this box:
I tried it six times already. It had worked before but not anymore. Please help!

I would have tried another browser but there is no choice. When I click “Login” the default browser opens. I could have changed the default browser in the Windows settings but I think it’s too much. This combination worked before. If there is a good chance that changing browser might help, please let me know I will try.

And why, oh why can’t we enter the TIDAL credentials into Roon directly like in the good old days?

P.S. Is there a way to roll back the Windows app to the previous version? Roon is almost useless to me now because I mostly listen to TIDAL.

I use Firefox so I logged out of Tidal. Logged back in, I did get that pop up but I ignored it as Roon was already logged back into Tidal and just hit cancel.

Hi @G_P — If you use a different remote device is there any change? While it should work with Firefox, trying a different browser would also be a good data point.

This was a change that all apps that integrate with TIDAL are required to make.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.