Cant login to roon account

Core Machine (Operating system/System info/Roon build number)

Ubuntu 20.04 VM running roon core latest update…

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet, unifi, pfsense

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

I was having issues “roon is having trouble verifying your connection with our servers” but I could listen to local music and internet radio but not Tidal. Then I disconnected Roon core and since cant log back in, getting Network error: Please check your internet connection. Ubuntu VM that is running Roon core can ping and other sites no problem including devices on LAN. I can also login to my Roon account in web browser. I also tried to make new core on windows machine and it let me go through login page and ask to disconnect the ubuntu core but I didn’t want to mess anything any further. I will attach log files.


Hi @Uros_Erste,

I’m sorry for the delay - as you might know, support is closed over the weekend. I appreciate you taking so many troubleshooting steps before even reaching out.

Have you tried rebooting your Ubuntu Core (powering off, unplugging for 30 seconds and turning back on)?

Should that fail, would it be possible for you to reset your router?

As for the process of switching your Core, you’ve done everything right! Since one Roon license can only be used on one Core at the same time, you are asked to deauthorize the session on the previous Core before continuing. This shouldn’t mess anything up. When you want to return to your initial Core, you’ll do the same :slight_smile:

We’ll stay in touch.

Rebooted multiple times during uninstalling and installing Roon core…
Router should be fine since I can ping everything from my roon core my roon core has DNS and
I can play Tidal tracks that were added to my Albums but if I go to Browse Tidal nothing is working…
I get Error loading page If I disconnect from Tidal also tracks become unavailable (as they should)…
I disconnected Tidal rebooted core got back in login to Tidal still nothing. Adding music to library is stuck and metadata improver is paused…
I can play Tidal tracks from theirs app from all computers and phones in my home…

Add im


Hey @Uros_Erste,

Thanks for the quick follow up. I appreciate you trying all the troubleshooting steps before.

It seems that the only thing which we have not tried yet is the DNS change in the Router. Can you please let me know if changing the DNS to Google’s DNS helps resolve this issue? You can use these Google DNS servers ( and verify if the same behavior occurs. As for instructions on how to change the DNS, I would refer to your Router’s manufacturer website for exact instructions.

Please let me know if this helps.

The router is fine! first photo are DNS servers that DHCP sends across LAN… Second are router DNS servers…


DNS of Roon core

Thanks for the screenshots @Uros_Erste. I’ve just notified our technical team so they can chime in to help.

They will reply on this thread as soon as possible :pray:

A post was merged into an existing topic: Trouble loading TIDAL content in Roon

Guys you should look in your ipv6 support it is probably broken in Roon 1.8… My solution was to disable ipv6 in ubuntu Roon core! I found older posts that say that ipv6 is supported, it was until 1.8 because my roon core stopped working after latest upgrade!

it was working for a while now even with ipv6 disabled after reboot it doesn’t work… In logs there is
Warn: Error in web request NetworkError (The operation has timed out.)

and now it is working again… this is strange… It has to be something with ipv6… I disabled it globali on my router for now but this is not a solution!

I found a way to disable ipv6 just in ubuntu, but still It was working before last update…

Hi @Uros_Erste ,

Are you able to properly log in to Roon outside of the Ubuntu VM on another Core?
Sometimes VMs require specific settings applied, so I would check for errors outside the VM.

You are able to unauthroize / re-authrozie the Roon Core as often as you’d like, the only limitation here is that there can only be one active Roon Core at a time. Can you please create a Roon Backup for safe-keeping and then verify if you have the same issue on your Windows PC?

A post was split to a new topic: Can’t login to Roon on CentOS 8

This topic was automatically closed after 19 hours. New replies are no longer allowed.