Can't login to Tidal - bad username password

Core Machine (Operating system/System info/Roon build number)

Rock Version 1.0 (build 174) stable Roon Version 1.6 (build 416) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Linn Majik DS

Description Of Issue

Can’t login to Tidal anymore. Keeps saying bad password while I know it’s working. I’ve checked for the tidal_account file it’s not there. I’ve tried rebooting, powering off and waiting. My Tidal subscription is still active as well. Please help!

Hi @Daniel_Smink,

Can you try refreshing the TIDAL Cache folder by using the following steps?

  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Also, I would double check that the same login is still working on the TIDAL web player ( I have sometimes seen the symptoms you describe when there is an issue with the TIDAL account itself.

Hi @noris

Tried the above sadly it didn’t help. works fine, tried logging in and out multiple times.

Hi @Daniel_Smink,

Are you using TIDAL elsewhere at the moment - your car, another music server, machine at the office etc ? If so, can you try to log out from that place and see if login starts to work.

Hi @vova No I’m not using Tidal anywhere else. In fact I changed my password so I’m logged out of all other devices. I did log into to try the login details and they work. But afterwards I logged out again.

Just tried again and it appears to be working. Not sure why as nothing changed.

I’m having the same problem. I can log in to the Tidal app, but not Roon. I tried logging out of the Tidal app, but it made no difference.

Hi Steven,

Try rebooting your Roon Core.

Cheers, Greg

I restarted my ROCK, and the iPad app asked whether I wanted to instal an update. I said yes. I was just able to log in on this iPad. Also now working on my iPhone.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.