Can't play to any endpoint except for iPhone

Hell everyone,

Same here. I can only stream to my iPhone. Other endpoints: no music. On ropieee I got the poster picture but it does not play. Rebooting everything does not help.

I was able to get a degraded mode by disabling Tidal (log out) AND rebooting the core. I can then stream my personal music.

If this could help Roon team, I had to re-log with Tidal when I install the update, everything worked. Later I forced a re-scan because I added personal files. Boom! Even after a night and rebooting the core, the system was dysfunctional. When looking at the service screen, Tidal was connected but there was a circle looping. Not sure what it means but I guess it is not normal.

By the way, this is why I prefer to have immutable containers with the binaries inside. If anything goes wrong you can go back to previous version. I understand your issue with database schema that can be updated but with an autobackup before updating container it’s not an issue and I could have reverted back. Just saying.


Does the development team confirm this bug?

Hi @Torpi,

We made a change in our latest release that affected the way that TIDAL login is performed, so a re-login is to be expected but this shouldn’t be something that you have to do on a consistent basis.

What other endpoints were you having difficulty playing to? What kind of Core setup do you have? Was your local library content also impacted by this issue?

Hello @noris,

Core is on debian. I understand that re-login was expected and that is fair. The problem is after that, I cannot stream anything, would it be local or tidal music. The only way to get something is to disable tidal and then I can stream my local files. Basically, logging to tidal blocks the system. I’ve tried many reboots before and after tidal re-login, re-delogging, etc… No luck.


Hi @Torpi,

Can you please try clearing out your TIDAL cache?

  • Exit out of Roon/RoonServer
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Hello @noris,

So, I moved the cache away and restarted Roon. Now, when I go to settings/services and click on Login (Tidal) it redirects to the webpage to authenticate. When this is done, it goes back to Roon but still it stays no connected.

But because I’m stubborn I repeated the login to Tidal 3 times. The 3rd was the good one. All is working properly now. There nothing special I could see in the logs about the connection to Tidal.

Thank you for suggesting to move the cache.

I am not willing to reboot the core right now (Covid 19 and no music is not an option) but will eventually.


Hi @Torpi,

Glad to hear that the TIDAL cache clear has helped resolve this behavior!

As I mentioned earlier, logging into TIDAL is something you should seldom have to do, but if you experience any further issues, just let us know and we can take a look.


All good, I’ve restarted the core and everything is alright.

Move dthe db to glusterfs volume at the same time and got better perfs overall. So at some point the issue gave me an opportunity to get something better :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.