Can't see external hard drive on MacOS [Ticket is in]

Thank you for the suggestion… My data drive is already available and visible on my desktop. My other applications that store data on it can access it Ok. I am able to browse the drive using Mac OS. However, Roon is unable to find it, e.g. Settings, Storage, Add Folder, Browse. My other drives show up, but not the one with my Music.

It has been some time but can’t you add the file location just below the Browse area.

My external SSD is direct connected via USB-C. It’s just hanging off the computer. Since all my other applications can see the drive, I have come to the conclusion that is has to do with how Roon resolves drives in its browser. I’m wondering where Roon stores its preference file. Usually, if one could delete the preference file, it would reset Roon to its default and perhaps I could reconnect. Here’s the first window that came up when I relaunched the updated Roon (1.3 Build 269).

screenshot_02

Here’s a screen capture of the Roon Browser window to locate a Storage Folder.

screenshot_03

What is missing is “Mark’s Data” disk (you can ignore Music as it is no longer being used for music):

screenshot_04

High Sierra and all my other applications can see “Mark’s Data.” Roon cannot.

Let’s flag @support to follow up with you.

It will probably help if you could post a screenshot of your Storage information (Apple > About This Mac > System Information > Storage) like this (in your case, select ‘Mark’s Data’):

Please see below:

Hi @Mark_A_Waidelich ---- Thank you for the report and sharing your feedback with us, both are very appreciated!

Moving forward, to help us better understand what could be going on with the mentioned external SSD may I very kindly ask you to please provide the following:

  • An expanded description of your current setup using this link as a guide.

  • A screenshot of your “storage” tab in Roon.

  • Besides the update to build269, has anything else changed in your setup since noticing this behavior? Remember, no detail is too small.

-Eric

Hi Eric,

Please see below. I’ll try to follow the @Support script in the future. I don’t normally spend a lot of time on the forums, but I’ve received excellent service from everyone when needed!

  1. My setup is pretty simple consisting of a Mid-Year 2017 15" 2.9GHz i7 Kaby Lake MacBook Pro running MacOS High Sierra 10.13, 16GB RAM, and an external 1TB SSD connected via USB-C (to USB 3) which contains about 400GB of music. I have been running Roon for a couple of months and love the UI and functionality, so much so that I dropped another very well regarded application. I have used it with HQ Player, but have found the built in DSP options to be sufficiently flexible to my other player, but with a superior database!
  2. I was running the latest version of Roon until Roon automatically notified me of the update to Build 269.
  3. Roon updated my current version to Build 269 and automatically restarted. I briefly checked to see that newly added material was automatically added to the database–it was–and exited the program. Then, I relaunched Roon again just to check things out, and poke around a bit in the new version. That’s when the app indicated that my one or more of my storage locations might be offline. I checked my SSD and it was clearly online and accessible.
  4. Roon sees my NewerTech GMAX RAID 1 mirrored drives and the PCIe system disk, but fails to enumerate the external SSD.

Subsequent to these issues, I uninstalled Roon using TinkerTool System Uninstallation Assistant and then downloaded and reinstalled version 1.3 Build 269. I was hoping that TinkerTool System would also delete any preferences files, but the previous user settings and reenumerate all the drive designations, as if it was a fresh install, e.g. I would have to enter my subscription information.

I then logged out of my Roon account and reentered my subscription information. Sadly, my external SSD is still missing in the Roon Browser.

Hopefully, this is helpful! I’m looking forward to being up and Roon(ing) again!

Here’s screenshot of the Roon Browser tab:

Regarding if anything has changed, nothing up to point when I updated Roon to Built 269, but the whole laptop is new, and everything was running Ok before the update.

Hi,
After update, 3.1 build 269, Roon no longer sees my external hard drive, it doesn’t appear in storage settings even though its on my desktop, Audirvana + and iTunes can both see it and access files stored on it. I also think the update maybe responsible for some strange behaviour my iMac started exhibiting around the same time such as highlighting of items/options in menu drop down boxes flickering between options when trying to select one, system sound effects randomly sounding and continuing until I switch it off inSystem Preferences and others, these behaviours are all random.

System.
Roon 1,3 build 269
27" iMac (late 2012),
2.9 GHZ i5, 16g ram
macos High Sierra V.10.13
2TB Lacie Minimus USB 3 external hard drive
7,810 tracks,

Hey @Mark_A_Waidelich @Peter_Hayns – sorry for the trouble here.

We noticed you guys are both running High Sierra, so we’re going to do some additional testing in house and see if we can reproduce the behavior you guys are describing.

We’ll be in touch, thanks for your patience guys.

1 Like

Please help, @support! I have the same problem. I have two external HDD’s with music for as long as I have Roon, and all of a sudden Roon no longer identifies one HDD. I am now missing the main part of my classical music. I too haven’t changed a thing to the HDD, e.g. name or path.

First, I have tried switching USB ports, rebooting the Mac, switching the HDD USB cables, rebooting the Mac etcetera. I have also tried my backup HDD instead of the one that Roon no longer recognizes. Both are perfectly identified by my Mac, but not by Roon.

Please note I have NOT yet upgraded to High Sierra (exactly to prevent things like these until any such bugs were solved).

Yup, we weren’t able to reproduce on High Sierra either. We’re investigating now, @Eric will be in touch as we gather information.

Anything notable about the drive that’s missing, or what distinguishes it from the one Roon is seeing, would be really helpful.

Thanks for your patience guys.

Hi @mike, both external HDD’s (as well as both my backup HDD’s) are WD My Book HDD’s. The only difference is that the ones no longer recognized both are 4TB, whereas the ones still recognized both are 8TB.

@mike, actually my last reply is incorrect: both 8TB HDD’s are WD My Books, but both 4TB HDD’s are WD My Book Studios.

@Mark_A_Waidelich / @Peter_Hayns / @koen ----- Thank you for your continued feedback and more importantly, thank you for your patience.

Moving forward, I have enabled diagnostics on all of your accounts and the next time your Roon cores are active an automated report will be sent directly to our servers so we can have a closer look into what could be causing this issue with the mentioned external drives.

In the mean time if you have not provided the following information, may I very kindly ask you to do so. Please see below.

  • The make, model, and specs of the device currently hosting your Roon core.

  • The make and model of the hard drive(s) you are currently experiencing this issue with.

  • Please post a screen shot of your “Storage information” (Apple > About This Mac > System Information > Storage) as highlighted in RBM’s post above.

  • Please verify how the drive(s) are currently mounted to the Core machine.

  • Very important - ANY additional insight you can offer in regard to the HDs being used will be of great value to our team. Remember, no detail is too small.

-Eric

@Eric,

  • The make, model and specs of the device currently hosting my Roon core:

51

  • The “Storage information” of the drive I’m currently experiencing this issue with:

  • The “Storage information” of the other external drive (the one I’m NOT experiencing this issue with):

  • I verified how the drive(s) are currently mounted to the Core machine. As I said, I’ve changed all drives to all USB-ports and the UBS-ports do not seem to be the problem, as the Mac recognizes each one each time. Please let me know if you need additional information.

I’m including a few other “possible” views, including my Lacie Thunderbolt eSATA hub

System Information:

screenshot_07

Thunderbolt Storage and Hub:

USB:

I wonder, would it be possible to obtain a link to the previous version of Roon? We could try installing the previous version and see if it restores our drives?

1 Like

While waiting for a permanent solution, I would also like this very much if possible. After a busy period, I was just looking forward to a few evenings of listening pleasure, as I have the house to myself for a couple of evenings (and my wife is not quite into classical music).

Hi Eric,

My HD is connected directly to my iMac via USB I think I mentioned before when detailing make and model that its USB 3.

Below is a screenshot of my storage information

All ---- Thank you for your feedback and taking the time to provide me with the requested information. Very appreciated!

Just to bring everyone up to speed. A ticket with all of your information is now with our developers who will be heading up the investigation into this issue. Once I receive some feedback on their progress, I will be sure to update this thread in a timely manor.

Lastly, I saw a few questions in regard to rolling back to the previous build. I must be clear that we do not support this action. In order for us to try and understand why this issue has occurred with your setups, everything must be “up to date”.

As always, thank you for your understanding and more importantly, thank you for your patience. We will be in touch.

-Eric