Can't see my connected devices


Whilst Tidal has been a little hit and miss over past few months it has, until recent weeks, been mostly hits and I’ve been managing to live with it in the main although never entirely happy. Unfortunately it’s now mostly misses.

I’ve adjusted the settings you mentioned.

  1. TIDAL played instantly after disabling this setting…but only for three tracks.

  2. Unticking the CSP option made no difference…TIDAL still doesn’t play.

  3. Tried all three options under TLS/SSL and Tidal doesn’t play under any of them.

Cheers and Happy Christmas


Hello @Michael_Blair,

Thanks for letting us know that information. I will be taking over your case while Dylan is out on leave and have been reviewing your case notes. I just want to confirm where you currently stand:

  • You are using the NAS as the Core and Local Content works as expected but TIDAL content is failing to play at times

  • Port aggregation is still disabled for both your NAS and any switches in this setup

  • Roon is allowed through any firewalls or antivirus applications you may have on that NAS

If this is the case here I would like to take a few steps back and ask you to change your DNS settings in the router. Please try to use Cloudflare DNS ( instead of Google DNS and let me know if that has any change.

If there is still no change, let’s try something else: Connect your NAS and a Roon Remote directly to your router bypassing any switches. Does the same issue still occur? If it does, I am wondering if the issue is with the router itself. If we can confirm the behavior with another router that would be a good test to perform here as well.

Apologies once again for the length that this issue has taken to be resolved, please let me know your findings regarding my above suggestions when possible.


@noris, thanks for your note Noris. Like Dylan I too have taken some time out :slight_smile:

Your summary of the issue is accurate. Over the (say) two week period after your last note TIDAL was pretty much working perfectly (which goes part way to explaining why I didn’t respond - sorry about that).

I have reactivated port aggregation between switch and NAS. Turning it off didn’t improve the situation and having it on doesn’t seem to make it any worse.

Firewalls/virus apps etc are all set to allow Roon and TIDAL through.

Now changed settings in router to use Cloudfare. This has not any positive effect either in my media room with Project S2 nor in the Study from Surface Book to Oppo HA1.

I’ve already tried connecting NAS directly to router. As per changes to port aggregation this didn’t work either.

As an update my setup has changed a little. NAS, switch, router and Project S2 are still the same . I am now using an Allo USBridge ( and my Roon Controller is via a Samsung Tab S4 (Android obviously :grinning:).

It may be of interest to note that my issues commenced arounf the time of Roon upgrade 1.5. These issues have always been intermittent. Right now, post 1.6 upgrade, TIDAL is completely dead via Roon. I can play music via TIDAL internet and TIDAL app (on PC, phones and tablet) but nor through ROON.

Hi @Michael_Blair,

Apologies for the continuing difficulties here.

Previously you were able to still use TIDAL with your other Core machines, just not through the NAS Core. Is this still the case, or are other Core machines not able to use TIDAL anymore either?

Hi Dylan, in recent months I had removed the other Core installs. I’ve now reinstalled the Roon Core on a PC and all works as it should. Problem is (still) restricted to just the NAS Core install.
I’ll try and remove the NAS install completely and then reinstall and see if that brings any joy.


Hi Dylan, as per my last suggestion…over six months ago I have removed the NAS install completely and all is working brilliantly now and has been for some months.

Sorry, I should have provided this feedback some months ago.

Currently very happy with Roon, so much so that I’ve upgraded from the allo USBridge to a Pro-Ject Stream Box S2 Ultra. Will also be upgrading Roon to lifetime subscription before next expiry.

Cheers and thanks so much for all your help.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.