Can't see my connected devices

Thanks Dylan, your recap is correct.

Regarding the SSD connection, instead of ‘weird’ I should probably describe it as not common. It is a ‘standard’ USB 3.0 connector. Pic here

My NAS comprises four standard hard drives. The recommended setup in my case is to use SSD USB attached storage for the Roon Core (database). Installing on standard HDD will only make my issues worse. Refer Chris Rienke blog re setting up Roon on a NAS.

Chris Rienke Blog re Roon on NAS

Looking further into this issue, I also came across this thread Roon/Tidal - Synology which seems to indicate that using a NAS might be problematic regardless of other issues.

Somewhat frustratingly my NAS solution has only recently started having issues; it has worked fine since October last year. Should I give up on the NAS and go with a Core on PC solution or are there other options to consider?

Thanks for the info, @Michael_Blair.

Yes, it’s definitely advised that you use an SSD to house the Core. There would likely be performance issues otherwise, but I was mostly curious to see if the experience was any different when housed internally, just to rule out any possible issues coming from the USB connection to the NAS.

Have there been any other changes recently that may be causing this behavior? From our troubleshooting here, we’ve determined that the network seems to not be the issue, and confirmed that running the Core from the PC is working exactly as expected, so there is something about the NAS Core that us causing this behavior.

Have there been any firmware updates for the NAS? Are you using any new software that makes use of the network (VoIP, AV, etc.)?


Thanks @dylan. One of the steps you had me take was to update the FW on the NAS to the latest version. This didn’t resolve or improve the issue however the issue existed prior to the FW update. I haven’t added any new software or devices to the network.
The only ‘change’ I can point to is the recent Roon upgrade to 1.5.

Hey @Michael_Blair,

I wanted to touch base and let you know that I’ve submitted a request with the technical team to get some feedback on why you may be seeing the behavior specifically on the NAS. I’ll be sure to let you know ASAP when I get feedback from them on this.


Hey @Michael_Blair,

My apologies for the delayed response here. I received feedback from the team and I have something I’d like for you to try which should give us some more insight into what is occurring.

  • Create a Roon backup for the database on your NAS
  • Stop Roon
  • Locate your Roon database according to these instructions
  • Rename the entire Roon (or RoonServer) folder to roon_old
  • Relaunch Roon, sign in, and configure a new install
  • Only sync with TIDAL and try playing TIDAL tracks as you were previously

Let me know if you still experience the same behavior with TIDAL during this test or if things improve here.

When you’re finished testing you can stop Roon and change the roon_old folder back to it’s original name so you can go back to the original Roon database.

Thank you,

Hi Dylan, I’ve followed the instructions above.

TIDAL does not play.

Thanks for giving that a try for us, @Michael_Blair.

My apologies for the continued troubles here. I enabled diagnostics on your account once more so we can get a new diagnostics report from this test and have passed everything along to the team for further analysis. As soon as I get feedback from them on this I will reach out to you with an update.

Thanks again for your patience during this investigation! It truly is appreciated!


Hey @Michael_Blair,

I spoke with the technical team about their findings today. They have a couple questions for you that should aid in their investigation.

  • Just to verify — This behavior occurs in all zones correct? Can you try playing through the OPPO and Pro-Ject and see if there are any differences?
  • Similarly, are there any differences when playing local content to both of these zones? They both work correctly?

Thank you,

Thanks Dylan, so now I’m back to the core on my NAS. The original one with both my local content and Tidal content.

Firstly I tried from my Surface Book in my study to my Oppo HA1. Local content plays no issues. TIDAL does not do anything via Roon. Also tried TIDAL from the TIDAL application on my Surface Book and it plays fine.

Then tried the PC in my media room using my Pro-Ject S2. Again local content plays without issue. TIDAL is not working at all via Roon. The TIDAL application on this PC is playing as it should.

Then tried the same PC using Oppo 203. Local content plays as expected. TIDAL does not play at all.

Also tried my Surface Book in my media room playing via Oppo 203. Local content plays as expected. TIDAL is, yet again, not working at all.

Using the Oppo 203 via PC or Surface Book, the Oppo display shows the TIDAL album art but the screen is otherwise unchanged from the most recently played local content (ie album and track details and progress bar and elapsed time don’t change).

Then I tried from the Surface Book playing to my Denon AVR6300. This is via AirPlay. Local content plays as it should. TIDAL also played!!! All content plays with a green light in audio display and an Airplay note.

Whilst I was playing around with the Denon AVR6300 I had forgotten to stop playback via the Oppo 203 (from the Surface Book). When I revert to the Oppo 203, TIDAL is playing!

Back to the PC via Pro-Ject S2 and both local content and TIDAL content all seems to be working as it should. I then changed a setting via Roon on the Pro-Ject S2 and TIDAL stopped working. Changed the setting back and TIDAL still wouldn’t work.

Then tried TIDAL track via Roon from Surface Book to Oppo 203. Took quite some time to start but played eventually. Stopped that, reverted to PC via Pro-Ject S2 and now have both local content and TIDAL playing.

Turned everything off and went back upstairs to study with Surface Book into Oppo HA1. Local content fine. TIDAL is a no go.

Back downstairs to media room…PC into Pro-Ject S2: local content fine; TIDAL is a No Go.

Then tried Surface Book into Oppo 203. Local content no issue. TIDAL won’t play. As per prior test with Oppo 203 I left TIDAL ‘playing’ and then tried the AVR6300 from the Surface Book. Local Content fine but TIDAL not working. Switched back to Oppo and TIDAL wasn’t working.

Then tried PC into Pro-Ject S2 again. Local content fine TIDAL a dead duck.

I trust this assists with resolution of this long outstanding issue.

Thank you for the test results, @Michael_Blair!

I’ve passed everything along to the team for review, I’ll be sure to update you as soon as I receive their feedback.

Kind regards,

Thanks for your patience as we have been investigating, @Michael_Blair!

The team reviewed the results of your test as well and we have some ideas as to what may be happening on the NAS. Can you confirm how much space is available on the drive where the Roon database is stored? There may not be enough free space available for the storage of the TIDAL files that you’re attempting to play.

Do you have Crossfade turned on?

Are you using any proxies that may be affecting the NAS network connection?


@Dylan. The drive is a Samsung 250GB V-NAND SSD 850 EVO. Checking the properties of the RoonServer in my NAS shows I’m using a paltry 994.3MB being 9430 files in 5228 folders. This appears to be my TIDAL library (as noted in prior posts).

I haven’t changed the settings for items such as cross fade so presume it is turned off.

No proxies are used in my network.

In a prior post I mentioned I had setup another PC in my media room. Last weekend this PC died and I am now back to exclusively using my Surface Book (in both my study and media room). When I start Roon the Surface Book does not see all audio devices. I can see the airplay device (AVR6300) and a networked device (Oppo203) but not my USB connected devices (ProjectS2).

Under settings>audio the list of devices connected ‘to the core’ flashes up every now and again but does not stabilise. These devices are not listed under ‘Select an audio zone.’ This is the same as I posted when I first raised these issues more than six weeks ago.

Hey @Michael_Blair,

I spoke with the team, and they believe that it may be possible that the cache is stored on a drive that is almost full. The team has found some documentation on the Synology website that explains how to choose the SSD you’d like you use for the cache. Can you try following the steps listed there (and outlined below) and see if you’re still experiencing the TIDAL issue on your NAS?

  1. Install the SSDs into your Synology NAS. Please see the notes above first.
  2. Go to Storage Manager > SSD Cache. Click Create.
  3. Select the cache mode (only available for models that support read-write cache).
  4. Find the drop-down menu and select the volume or iSCSI LUN (Block-Level) on which you wish to mount the SSD cache.
  5. Choose the SSDs from the list. Data on the SSDs will be erased, so please make sure no important data will be deleted.
  6. Click Apply.

For the ProjectS2 — If you connect it directly to your NAS do you experience the same behavior?


When you say the cache is stored on a drive that is almost full are you referring to the Roon cache? Or my Synology cache? The Roon cache is only 1.12 GB. The NAS has used storage of 4.02TB with available storage of 16.92TB. The NAS is setup essentially as one great big hard drive for storage. Lack of space for the cache is categorically not an issue.

The notion of removing one of my HDDs from the NAS and installing an SSD to use as a cache is not something I consider necessary. Refer Chris Rieke’s blog on running Roon on a NAS.

The ProjectS2 needs Windows drivers, I don’t believe it will work from a NAS.

Hey @Michael_Blair,

First, apologies on the delayed response here Michael. I’ve been communicating with the team about this investigation and wanted to make sure we had solid next steps to move forward. I also appreciate the additional information provided above, and you expanding on the drive details. The team and I had a long discussion about this today, and I wanted to give you an update on our current thoughts.

When we previously had you use the Windows Core we confirmed TIDAL was working without issues, and narrowed things down specifically to the NAS. Through the various troubleshooting tests you’ve performed, including changing how the NAS was connected to the network, the NAS has consistently exhibited the same behavior. We have many users with similar NAS setups that are able to stream TIDAL without issues, so there must be something specific to your environment that is different.

Since space available for caching doesn’t seem to be the issue, the team believes that there may be some settings on your NAS that are different than what we typically see and may be contributing to this behavior. In order for us to better understand this, we are hoping you’d share some screenshots of you NAS’ settings. In Control Panel for the NAS there are settings for Network as well as settings for Security that may provide some insight into why the NAS is unable to play TIDAL content. If you can get complete screenshots of your settings (including each tab) for these two sections of Control Panel we can do some additional investigation regarding your settings.

While we do this, we would like to recommend that you use you Surface device as the Core machine. This will again allow us to confirm that you are able to play TIDAL via Roon outside of the NAS. You can also try connecting the Surface to the exact same Ethernet connection as the NAS currently to confirm that there is not something networking related at play here.

For the ProjectS2 — Can you confirm how you have this connected to your Surface? Is it connected directly via USB or is it connected to a hub that is then connected to the Surface? Can you confirm that it has all of the appropriate drivers installed and they’re up to date?

I know this troubleshooting process has gone longer than we would have liked, and for that I apologize. This is definitely not the typical experience for NAS users so we are hoping that the settings on your machine will shine some light on why your experience is different.

Kind regards,

@dylan, screen shots of NAS setting as requested:






ProjectS2 is connected directly to the Surface, no hub is involved. Driver/firmware is the latest version. I note that Roon cannot see the Project S2 however from my Surface I can use the ProjectS2 with other software (ie Tidal). It seems the issue is with the Roon software.


Thanks for the screenshots, @Michael_Blair!

The settings on the NAS appear to be okay, but I’m sending this over to the technical team to take a closer look at and see if they can replicate similar behavior by using these settings.

In the meantime, to further test the network, I’d like to propose this:

Using the Surface as the Core, try connecting it to the same Ethernet cable as the NAS. The Surface at this point will be using the same exact network connection as the NAS. Are you able to play TIDAL with this configuration? I know that you previously tested this Ethernet connection with other devices, but I don’t think we tried it will another Core machine playing TIDAL in the same exact way.

Thanks for confirming this. On the Surface Book can you confirm whether or not you have any active antivirus or firewalls? If you do, try temporarily disabling them. Can you confirm that there are firewall exceptions in place on this device for Roon and RAATServer?


Hi @dylan, have you heard back form team re NAS settings?

I have previously tested the Surface on the same ethernet connection as the NAS. This was when NAS was in my study. The difference is that the Surface doesn’t have an ethernet socket so I was going through a hub for wired network access. My Surface is currently connected in this way (as the NAS is still in the cupboard under the stairs). TIDAL thru Roon to my Oppo HA1 works great. The ethernet/network connection seems to be working fine.

We’ve addressed firewalls in previous comments. I’ve turned these all off in the NAS and confirmed that exceptions are in place for Roon and RAAT server on the Surface as well as for TIDAL.


Hey @Michael_Blair,


The team is investigating this based on your settings. As soon as I receive their feedback here I’ll be sure to update you. Knowing that the Surface works when connected to the exact same port is definitely a good data point. I’ve let them know about this and will be sure to update you ASAP when I receive the rest of their feedback.

Project - Surface Connection

Thanks for confirming firewall settings, I know we had previously done so for some of the other devices, so I just wanted to be sure to rule that out on here as well.

Just to confirm — When the ProjectS2 is in this state you’re able to play to it just fine outside of Roon, correct?

If so, I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more (connect the S2 to the Surface) and note the time at which the you do so. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


Hey @Michael_Blair,

I got some feedback from the team regarding your settings and we have a few things we’d like for you to try. Below are a series of settings that we want you to try to adjust. After adjusting each setting please try to play TIDAL content and let us know if there is any change in behavior after each.

  1. Disable the Enable the “Server” header in HTTP responses option

  2. Disable the Improve security with HTTP Content Security Policy (CSP) header option

  3. Try every option in the below screenshot: