Can't see or select Mac OSX audio zone for Roon Player

Roon Core Machine

Roon Core v1.8 (build 931) and Roon Remote on the same Macbook Pro (13-inch, early 2011) 2.7 GHz Intel Core I7. Memory 4 GB 1333 MHz DDR3. OSX Sierra, 10.12.6

Connected Audio Devices

miniDSP DAC. Plays audio fine from other applications on the computer.

Number of Tracks in Library

Library size ~8,600 tracks

Description of Issue

I can’t see the computer’s output as an audio zone from Roon Player (or elsewhere) on this machine. This has worked in the past, but no longer.

Roon player sees and allows me to play through the rest of the devices on my network. What am I missing? Please help.

@Jon_Osborne1 just to clarify, are you running a separate instance of RoonServer on your core in addition to running the Roon app to control it. Is that correct?

If so can you please do the following:

  • Quit out of the Roon app
  • Quit out of RoonServer
  • Open a Terminal window and paste in the following command:
    /Applications/ -colorconsole - noexit

Please paste the output in a response here and once done you can Ctrl-C in that window and restart RoonServer.

Hi @AMP, thanks for your reply.

Yes, I am running a separate instance of RoonServer in addition to the Roon app to control it.

After following your instructions, I get the following:
00:00:00.019 Info: Starting RAATServer v1.8 (build 931) stable on macosx

Hi @AMP – just wondering if there is an update or next steps on this one?

Hi @Jon_Osborne1,

My apologies for letting this one fall through the cracks. Our support team is a bit overwhelmed at the moment and I’m helping out where I can.

Thanks for running that test as it eliminates a number of potential causes here. Do you have the macOS firewall enabled on this computer. If so, are you able to see your local audio devices if you turn it off and restart RoonServer?

Thanks @AMP.

macOS firewall is not enabled, it’s switched off.

I tried restarting RoonServer, tried restarting the computer.

Any other suggestions?

Make sure the zone is not set as private:

Thanks @BlackJack. But I can’t see the zone to change that setting. The device simply doesn’t show up as an audio zone. Or is there a way of resetting it?

Hey @Jon_Osborne1,

Thank you for reaching out to us with your question, and my sincerest apologies for the delayed response and for your wait. We’ve made some recent changes to the support team structure and some reports have experienced a longer response time than usual.

I’m sorry to hear that you were having issues with connecting to your OSX audio zone. Since some time has passed I wanted to touch base to get your current status. If you’re still experiencing this problem on the latest Roon build (952) and need assistance please let us know.

A follow-up question for you if you’re still running into this issue: is your firewall set to allow ROON and RAAT? Are you running any VPN’s?

We’ll be watching for your reply and get back in touch as quickly as we can. Thanks!

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.