Can't see ROCK on my laptop, Window 10 file explorer

Core Machine (Operating system/System info/Roon build number)

**ROON REMOTE RUNNING ON DELL LAPTOP, WINDOWS 10 HOME, VERSION 1903 2019/07/13, OS build 18362.356

LINKSYS Velop node (primary) then ETHERNET CABLE connected to NUC

**Audio Devices


Description Of Issue
Got rid of my old router (slow speed, lots of drops, constant restarts needed) and started using my Velop Mesh connected directly to my Xplornet modem(rural internet access is so much fun, lucky to get 2MBPS). My NUC is plugged into my Primary Velop node, the other two nodes are linked wirelessly. Initially was pulling my hair as nearly everything had disappeared: my digital library on my NUC, my bluesound speakers only the CA remained(!).
Gave myself calluses doing reboots on all my speakers,fiddling with various ethernet cables and finally gave up. Then 24 hours later my Bluesounds reappeared and even after an update a few days ago, all is good on that front. Gotta love those wall Gremlins that work during the night.

My only(latest) issue is that I can no longer see my ROCK on my Windows File Explorer and can therefore no longer add newly ripped CDs or Downloaded Flacs to my ROCK storage. I even tried plugging my NUC directly to my laptop with an ethernet cable but nothing was seen. I can still use my laptop as a remote without any problem.
I have no idea how to fill up all those 1848GB sitting on that beautiful NUC.

I would also love/need to add a basic switch (Linksys SE3005) so I can bring the internet to the man cave deep in the basement(forget wifi there). When I tried, lost the ROCK completely.

Thanks in advance.
p.s. perhaps there should be a way for the OP to self assess his knowledge of computer/network/gremlins to assist those giving advice.
To use a school analogy, k-13, post secondary, Master, PhD and Sage
BTW, I’m barely into middle school.

Are the NUC and the laptop on the same subnet? Eg, 192.168.1.* ?

Can you access it by hitting Start - Run \\ROCK ?

In Win10 you may also have to add support for SMB 1 thru the control panel, as it will normally not allow connections to devices running smb1 v1 for security reasons.

Hi @Sylvain_Duchaine,

First, let’s focus on connecting the Windows machine to ROCK and then we can take a closer look at the switch.

On the Windows machine, are you able to access the ROCK Core via the Roon app? Are you able to access the Web UI?

What are you entering into File Explorer to try to connect to ROCK? If you use the IP address is there any change?

Hi Dylan

On my Laptop, I can access the Rock with the app without any issue. I can see all my albums, see my audio devices, and control them, in other words, it works.

Not sure what you mean by “access the web UI”? Is that the Webpage where I can reboot my ROCK, see the basic info re built and how much room left on my HD?

Remember, middle school…

I never entered anything, it usually showed up on its own, way down at the bottom of the menu under “Network”.

Never knew to try the IP address, mind you, not sure where to enter it either!

If it’s that simple…

I’m away from my set up so I’ll have to try later, with instructions :slightly_smiling_face:


Yes, I checked that. Learning about stuff I had no desire to know about

That rings a bell, may have had to do this in May 2019 when I started off on this adventure, I’ll dig up what and how to do that.

Checked the SMB1 in control panel, all the boxes have a checkmark.
even did a check to confirm that my Windows 10 install has SMBv2 enabled and it does.

Hi @Sylvain_Duchaine,

You can read about the Web UI here. Let me know if you follow the instructions there if you can successfully connect. If so, you can find the IP address of the ROCK Core there.

Next, you can use this IP address to try to access ROCK via File Explorer on Windows. In File Explore, enter the following:

\\[IP ADDRESS]\data

Above, make sure to replace [IP ADDRESS] with your actual IP address found in the Web UI.

Let me know how this goes and if you have any questions!

I can see the Web UI no problem,
I tried just entering just the IP address I. The search bar of file explorer but nothing happened, literally nothing.
I’ll try with the extra // and /data

Hi Sylvain,
I have this problem too, from time to time. When I first set up ROCK it was listed immediately. But every now and then it disappears from my list of network devices, but when this does happen, some of my other network devices also disappear. Eventually, (usually after restarting the computer and using it a while) the devices reappear.
While this won’t help your immediate problem, what I have done is map ROCK as a network drive.
Even when my list of network devices get messed up, the mapped drive is virtually always listed. This helps me get more reliable access to ROCK files (especially internal storage).

Hi Scott
Yeah, that sounds a lot like what was happening to me before. Kinda random, but mostly could see and access ROCK on my laptop.
I kept hoping that it would"fix itself" as in the past but not so fat. Thanks for the link, can’t wait to try it out and I’ll report back. I get the feeling we are not alone.


I think that should be \\[IP address]\data. Backslashes, that is.

You can also try to map a network drive to the Roon drive.

In File Explorer click on “This PC” then “Map network Drive”.

Enter \\[IP ADDRESS]\data.

Probably need to check “Connect using different credentials” and on the resulting screen enter the appropriate id/password.

Apologies @Sylvain_Duchaine — I typed the above incorrectly and have now fixed it. It should be \\[IP ADDRESS]\data.

well, putting in the \IP\data worked, it’s now under network were it was before, just now it;s called [ip address], functional if not as aesthetically pleasing as “ROCK”.
Now I guess I’ve run out of excuses and better start ripping again.
Thank you all, once again for your assistance in dealing with this issue.
Now, I just need to work up the courage to try that switch.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.