Can't see Roon Bridge (RPi4, HiFiBerry Dac+ Pro)

Core Machine

Roon Version 1.7 (build 610) stable (64bit)
WD GREEN 120GB SSD for the OS
2TB HDD for data

Network Details

Bridge with Ethernet to FiberHome AN55-02-FG
Core with Ethernet to FiberHome AN55-02-FG
Remotes with WiFi to FiberHome AN55-02-FG

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Raspberry Pi 4B 2GB
HiFiBerry Digi+ Pro
Raspberry Pi 4 power supply 5.1V/3A
Coax connection to Sabaj A4
Samsung Galaxy S20 (wifi)
iPhone 6s (wifi)

Description Of Issue


I have used the above configuration more or less without issues and it worked fine with both HiFiBerry OS or Roopieee OS. Before I went on holiday I have unplugged the system however it did not go back to normal after I wanted to use again.

I believe I have tried many things with no success unfortunately: different LAN cables, different LAN ports to router, different SD cards, reformatted the SD cards several times, tried both OS (HiFiBerry and Roopieee), restarted core, reinstalled core - no permanent success at all.
There were brief instances when my Pi/DAC was recognized as manageable Roon Audio zone but that lasted like 10 seconds, or I saw it as an AirPlay option, but it quickly got dropped and was not able to make it work at all.

What is weird is that my iPhone sees the Roon Bridge within the “About” section but does not recognize it as an Audio Zone.

I am clueless now. Please do let me know if you need further inputs from my side. Thanks.


There may well have been updates in the time it was off. I’d check firewall settings to start with and then go through your devices switch it all off then bring the network up followed by your core and end points.

Thanks Harry for the quick response.
Unfortunately, that approach did not resolve my issue.

However accidentally I have found a bit unorthodox workaround. At some point I realised that the primary LAN port worked for the RPi (the secondary doesn’t and I still don’t known why). So, I temporarily connected my core/PC via the secondary (i.e. slower) LAN port to the internet and used the primary for the HiFiBerry. This way I was able to configure it’s WiFi connection in the browser and voilà, it worked.

Hello @Tamas_Orosz, glad you found a solution! Please let me know if you have any further issues with this device.

A few weeks ago I’ve subscribed to lifetime and decided to create another endpoint (this time for my work desk):

  • RPi4 model B 2GB;
  • RoPieee XL;
  • ifi Zen;
  • wifi to router.

Unfortunately, I’m facing similar issue.

can see device as Roon Bridge within “Settings: About”

can’t see device within “Settings: Audio”

I switched off the router firewall, restarted router multiple times, restarted core multiple times, restarted Pi multiple times and reinstalled RoPieee also.

Is the USB DAC connected and powered up?

Yes, and it works fine if connected to my iPad+camera kit combo.

Update 1: Your comment made me think and checked if it works with the Dragonfly Cobalt. It does!

Update 2: no problem with Zen if connected to core

What can be the problem with the Zen (powered by external power supply) + RPi combo?

The peculiarity of USB means that even with its own PSU the USB input of the iFi probably cannot draw enough power from the Pi.

Hey Henry. I changed the custom USB data cable bought for the Zen to a printer cable and that solved the issue. Thank you :slight_smile:


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.