Can't update Core to 1234

Roon Core Machine

Intel NUC 8i5 8GB RAM, Roon v2 build 1232

Networking Gear & Setup Details

ZTE MF286D → TPLink TL-SG108S unmanaged switch → ROCK

Connected Audio Devices


Number of Tracks in Library


Description of Issue

I just opened up my Windows Roon client and spotted there were some updates. It has downloaded and installed Build 1234, but each time I click to install the update for ROCK I get the message “There was an error checking for an update”.

Still having this problem…

Is your Core on a NUC/ROCK system? If so, you can try to reinstall RoonOS using the Web Administration Interface. That should also install the latest version of Roon Server for you.

Hi. I’ve tried that and got the following message:

There was an error downloading Roon. Please check your internet connection. {“status”:“Failure”,“exitcode”:10}

There isn’t anything wrong with my internet connection, though. And I have no problem streaming from Tidal although I have been having problems with radio stations as per my other post.

Have you tried rebooting your 4G router, followed by rebooting your ROCK/NUC?

I had tried rebooting both before to no avail but after reading your post I thought I should give it another go and this seems to have sorted the problem. It also seems to have sorted the radio problem so there must have been something silly going on with the modem/router.

1 Like

Yes, sounds like DNS issues, as you were suffering Radio playback issues as well as update download ones.

Agreed. I think DNS was the most likely cause of the trouble here.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.