Can't update Roon ROCK to 2.0

Roon Core Machine

Roon ROCK on a pretty powerful quad core NUC with 16GB RAM - can’t find specs offhand - ran 1.8 with DSD upsampling in five zones no problem with library of 150K tracks

Networking Gear & Setup Details

Vodafone UK router & Tenda MW6 mesh routers

Connected Audio Devices

Raspberry Pis ethernet’d into mesh router boxes with DACS/amps etc running off those separately

Number of Tracks in Library


Description of Issue

I can’t update Roon ROCK to 2.0 - I thought I had but maybe it has autoupdated to 1.8 Legacy having read a few other forum posts?

I have followed the instructions twice about renaming a branches folder and a Zoho 10byte download and that hasn’t worked. Anyone got any bright ideas besides downgrading to 1.8 (presumably more faff? Who knows). I was expecting a really simple 2.0 update process but this really isn’t, and now I haven’t had music for a day or two…

Thanks in advance - John

This may well be helpful too - I get this on my Mac and then a similar message on iPad/iPhone

Hi, @John_Merritt, sorry to hear about your troubles. Could you, please, do the following and see if your issue is solved:

  1. Go to the /Data/ share (instructions) and create a folder called branches

  2. Download the following file: roon_2-0 (It should be named roon_2-0 and saved with no file extension)

  3. Copy the file into the branches folder previously created

  4. Rename the file to roon (instructions on how to rename files: Windows / MacOS)

  5. In the Web Interface, click “Reinstall” under Operating System



Hi @ivan, I’ve done this twice already. Is there any chance there’s something else I can try? Thanks - John

Thank you for your reply. Am I getting it right that you are pushed from 2.0 back to 1.8 after performing these steps or these steps do not work for you and production 2.0 is not installed? We fixed a problem on our update servers last night, so I would suggest to try again.

Sorry for the trouble.


Thanks for getting back to me - I tried connecting to the Data share and uploading the file etc at maybe 6/7pm GMT last night and both times nothing happened - I never got onto 2.0.

When 2.0 was released I did update successfully just through the app and I think I was downgraded the other night automatically once 1.8 Legacy came out…

Thanks so much for trying to sort me out! I’ll be home in a few hours and try again and see what happens.

Cheers, John

Tried many times, still not workings

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.