Can't use Roon anymore. Unable to play on my Sonos speakers

Roon Core Machine

Dell XPS i7 16GB RAM (NUC is on a holiday, so using my laptop instead)

Networking Gear & Setup Details

Ubiquiti unifi. Was working with Roon core on NUC

Connected Audio Devices

Only 2 sonos play:1’s paired as one stereo pair.
This is a light setup with roon on my laptop and a pair of play:1’s.
I have a much more complex setup with a lot of more sonos speakers and endpoints, but now I just want to run Roon of my laptop and stream to a pair of sonos speakers. Nothing else is connected.

Number of Tracks in Library

25K Tracks

Description of Issue

Hi, I don’t know what is happening, but I’m unable to use roon to stream to a stereo pair of play:1’s.
When I try to stream something to it, it never starts and states ‘roon lost control of the audio device’ after some seconds. When Roon was running of my Roon Core on my NUC it worked.
If I play using the local output, everything works. If I use the Sonos app to select an album on Qobuz it works. But the same album through Roon doesn’t work.
Wat could cause Roon to be unable to stream to a pair of sonos speakers?

Is roon exception in the Windows firewall?

I don’t think I adjusted anything like this.
How do I add that exeption?

Kind regards,

Hi @Thomas_Vandromme ,

Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.


Hi Noris,
Thank you very much, this worked!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.