Can't use smb share [ solved, syntax wrong ]

Can’t see why there is no nfs share. Connecting to my NAS has been impossible!
SMB share is inadequate.

[quote=“Chris_Routh, post:1, topic:14227”]
SMB share is inadequate.
[/quote]May I ask why?
Does your NAS not support SMB
What NAS do you have?

Cannot create an SMB share from my NAS to my mac that does not require that I mount the share to my mac first.

Freenas is what I have

I’m surprised that there is no NFS share by default.

Where does Roon (or RoonCore) run? On the Mac?

What do you mean there’s no NFS share? Roon will happily access a NFS mounted directory tree - just mount it then point to it.

Ah OK. In that case I will revisit my settings and report back on my findings.
The issue I have is I would like to connect to my NAS by using the network option. When I try to do that I get the error message seen here:

If I mount the drive first and then create the path in the local folder option I admit I can see the drive.
Is there any explanation for this?

This is the first time that I’ve heard of a NAS that required a SMB connections to be mounted on the Mac before it can be used. To be honest, I do not really get the purpose of it.

Are you sure this is correct? What happens if you don’t mount it on your Mac first and enter the smb:// path in Roon?

all our smb sharing mechanism does is provider a helper to do the mount for you. if you really need to access using non-smb, just mount it yourself.

“What happens if you don’t mount it on your Mac first and enter the smb:// path in Roon?”

It doesn’t work. I get the error as above (same error whether smb or nfs share).

Could you post your smb-line here?

It won’t work just to replace the nfs by smb. The path after the IP address is in most cases different and for smb you need to add the share name directly after it.

Your NFS-line


will for smb likely be (if “music” is the name of the smb-share in FreeNAS)


Sorry, if you tried that already. I am just speculating here a little bit about the cause as it seems unlikely to me that a smb share needs to be mounted on the OS first… :slight_smile:

You solved it! (I’ve now put into the share smb://ip-address/name-of-smb-share)
My understanding of SMB shares has just gone through what’s known as a ‘quantum leap’!
Hey, that just shows my ignorance, impatience and god knows what else…
Many thanks for taking the time to help me out.
Very best wishes,

Chris R


Same issue here. Needed freenas smb://host.local/export_as_name, not MacOS file manager name.