Catastrophic Failure

Core Machine (Operating system/System info/Roon build number)

Build 186

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Unmanaged Switch
Ubiquiti Networking

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos Play5s, Play1s, SUBs, Beams, iOS Devices, Audioquest Dragonfly Red

Description Of Issue

Fully functional from December 2018 until February 10th.

Started skipping tracks, remote disconnecting, etc

New Samsung SSD w/ Clean Roon OS Flash a month after failed attempted at reinstalling the OS from the control panel.

Syslinux Uncompressed Error seen early on in flash attempt.

OS Successfully installed

Audio Devices Appeared
Music Library of 3k began to compile

Restore DB - Error Contact Supporat Suggested
Audio Devices Missing (All)
No Library (Qobuz, Tidal, or Local (NAS or Bkup SSD)

No Access to Roon (Not seen by iOS or Desktop remote)

Unable to Wipe database without reflash.

Hi @Daniel_Moretz,

Welcome to the forum.

Can I please ask that you use these instructions to access your ROCK logs and provide a copy of them via Dropbox / Google Drive? If you don’t have either service, just let me know and I can provide alternate upload instructions.

I wonder if a marginal power supply could be causing such issues? I was playing with a 12 volt supply to my NUC and its was only a 30W supply I found out and 2A limited and my NUC was all over the shop stability wise. went back to the supplied unit and all was well…so a marginal PS is trouble I know first hand.

3 posts were split to a new topic: Changing cores problem

Thanks Norris!

Hi @Daniel_Moretz,

Thanks for sending those logs over. I am looking through them and unfortunately in this case I am seeing signs of low level corruption in your database.

This type of error is extremely rare for us and not one that we see often. Our database infrastructure is designed specifically to prevent this type of corruption, and we don’t take this class of issue lightly.

We’ve traced a few reports like this in the past to hard drive integrity issues but generally speaking, this means that Roon is reading information from your hard drive that is different from what was originally written, and the database is now unable to load properly.

What’s Next?

I would suggest setting the current database aside by using these instructions:

  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • Verify if the fresh database works as expected for a few days to a week
  • Restore from a backup (if available)

If you are still having issues after setting the database aside, I would suggest re-flashing another USB drive (using Etcher to do so) and try reinstalling ROCK from the flash drive.

Apologies for the trouble here.

Having some trouble with the USB installer prepared with Etcher. It worked initially when I flashed the new SSD (before reaching out to support intially). However, with the same USB 3.1 Memorex Flash Drive I am receiving various errors on multiple attempts.

Hi @Daniel_Moretz,

Have you tried using a different USB to perform the ROCK install yet?

It is not clear if the flash drive is problematic here or if it is the NUC hardware is, so please try using a different USB drive to eliminate one of these possibilities.

I know you mentioned you replaced the hard drive earlier, but you may also want to try running Memtest x86 to check the RAM on the NUC.

I’ve tried multiple flash drives for the install. I’m currently running Memtest x86 and have over 800 errors. I’ll let the test continue to run. Would you advise new memory at this point?

Hi @Daniel_Moretz,

Those errors are not a good sign. I would advise first trying to re-seat the RAM and if the same issues occur, I would look into a purchasing a new set.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.