CD Ripper Unresponsive/Locked Up

Description of Issue

My Roon Nucleus arrived on 1/18 and I am very impressed with it (and your software). I have been ripping CDs directly to the SSD installed in the Nucleus for a few days - but ran into an issue yesterday. CD Ripper shows that the last rip was successful - but I could not eject the CD and no matter what I do, the section of the screen continues to show the same. I have attached a screen shot

I have restarted the SW a few times, Powered down the Nucleus after disconnecting the External CD (USB attach). At first I thought that it was an issue with the External CD Drive - but after disconnecting it from the Nucleus I attached it via USB to my Windows desktop and it is working perfectly.

Would appreciate your assistance in “unlocking” the CD Ripper

Thank you in advance,


1 Like

I have exactly the same problem with my NUC ROCK. I just gave up and installed dbpoweramp. Would be really interested in a solution.

Hi @Dean_B ,

We are aware of this issue and there is an active development ticket regarding this behavior.

I cannot comment on a timeline of when the fix will be released, but this is something that is on our radar and that we are working on.

In the interim, we have found that a hard reboot (stop RoonServer on the WebUI and reboot the entire Nucleus) helps resolve the issue, I would give that a try.

Hello Noris

Thank you for your quick and informative response.

I have tried rebooting the RoonServer and Nucleus - did not resolve the issue.

So when the fix is released, will it be included in an update to the Roon Server SW?

Thank you


Hello @Dean_B ,

Did you get any error messages when attempting the reboot? The Nucleus power needs to be fully turned off to clear the error (the power light on the Nucleus should go off).

This issue will likely be resolved via a RoonOS system update (as opposed to a regular RoonServer update). RoonOS system updates are very rarely done, but this interaction is due to an interaction with the system, not the RoonServer software.

Hello Noris,

I tried shutting down the Nucleus completely (power light went off).

It did not resolve the issue.

I ended up ripping CDs to my PC then copied over to the Nucleus so in the short term all is fine. I still have more CDs to rip - ripping to the PC is working just fine.

I would like to be able to rip directly to the Nucleus in the future - I will wait for the system update. If I have time this weekend, I may try to reboot/power down the Nucleus again per your points - but I am not confident that will resolve the issue


It won’t fix it so I would not bother. Use a pc to rip like the rest of us have ended up doing. They seem in no rush to fix this issue as it’s been around for at least 18 months and their has been other update to RoonOs in that time. It will repeat again even if you get it to work for a few times.

Do CD drives no longer have a small hole where you can force an eject with a paper clip?


Thank you for your assistance and input - I really appreciate it.

I disconnected the CD Drive from the Nucleus and attached it to my PC. Was able to eject the CD and have been using it to rip the CDs to my PC without any issue.

I am planning on ripping CDs to my PC - if/when the update is installed that resolves the issue, I may try ripping to the Nucleus in the future - but for now ripping to my PC then copying to the Nucleus is working perfectly

Thanks again,

1 Like

Hi Dean the PC/Mac approach offers other improvements as well so may be worth sticking with long term.

A package like dbPoweramp check’s the rip’s against known good database. Names the file’s in your chosen folder structure and easily allows you to keep multiple backups of the actual music.

Roon backup is just the database and the metadata for the music files is only stored in Roon, so if anything was to go wrong with your database then you might lose information.
Mp3tag is another great tool to work with dbPoweramp and something like syncback to synchronise the files to the server and you are off and running.

Multiple tools exist for all these, but it gives you some ideas.

While I agree that this bug has been around for a long time, it’s not the case that there have been updates to RoonOS since then.

The bug was introduced with the release of Roon OS build 227 in August 2020. There have been no new builds released since then.

I had it before that version Geoff.

Did you report it? I seem to recall that the first reports started coming in in September 2020…

No for me it stated with some earlier ones the same year. I ended up buying a new cd drive first to see if it was that. I had hoped it would be fixed in the subsequent updates but it didnt.


I would like to thank you and everyone else who have provided me with great insight and knowledge.

I agree with your points about dbPoweramp and SyncBack. I have been using dbPoweramp to rip CDs to my PC and have used SyncBack for many years.

I am not familiar with Mp3tag but will look into it later today.

Since this community has much more experience with ripping CDs etc. I have a question.

I have ripped almost all of my CDs to FLAC. I still have a need to burn music files that I have ripped to CDs (2 of our cars are older and have fully functional CD changers/players). Looking for recommendations on converting FLAC to MP3 and burning the MP3s to CDs. I have a Windows based desktop.

I realize that I can select to have files ripped as MP3s in dbPoweramp - but would prefer not to have rip all of the CDs again.

A few years back I did this by using iTunes to rip files from CDs and then burn them to CDs.

Thank you in advance

1 Like

Dean great that you already know all these apps, so that saves you time and money.

Mp3tag is a fantastic little app that will do all sorts of metadata editing and file renaming etc. Every rip I do goes into that for checking the metadata, and downloads for renaming to my preferred naming convention :see_no_evil:

Even better news for you is that dbPoweramp has a tool to do what you want. It has a batch converter tool that will mass convert flac files to any format required.
I convert all the high resolution files to cd quality using the DSP feature. I also occasionally convert hundreds of tracks to MP3 format for lower quality device’s.
The batch conversation process is amazing and will do 16 files at a time on my fastest machine meaning conversation of several albums at a time takes less than a minute.

Hopefully this helps.

1 Like


This is immensely helpful - thank you very much.

I will admit - I had not dug into dbPoweramp to determine if it had a converter. I appreciate your letting me know about it and also providing your endorsement of the results

One more question - do you (and/or others) have recommendations on SW/process to use to burn MP3s to CDs (after I have converted them from FLAC)?

Thank you again,


1 Like

Dean sorry it’s been many a year since I burned a music CD and probably used Windows media player for it back then.

There might even be something built-in to dbPoweramp converter, but I have never needed to look for this and I am out of the house today.

Hopefully someone else can respond, it’s a pretty tech savvy crowd here, just depends on someone having a need to do what you are looking for.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.