Change password for NAS smb folders?

Roon Core Machine

Roon core in VM (ESXi) on Ubuntu 20.04

Description of Issue

I changed the password to the SMB account that connects to my NAS music shares and Roon backups.
How do I reflected that in Roon? I see no option to change the existing password under edit?
If delete and add the NAS folder again, will I lose my existing library?

Cheers,
Nigel

@Nigelc - if required than here:

That’s adding a new share.
I want to amend an old one!

@Nigelc - Just add a new one, if it than works, remove the old one. That is the way I do it on my QNAP NAS.

And the library index will remain?

I can’t add the same share while it is still “mounted” :frowning:

@Nigelc - Sorry, but I don’t now what you are doing.

I know this works on my QNAP NAS: smb://127.0.0.1/Multimedia/Music

Ahh I see.
You are running Roon on your QNAP NAS? “127.0.0.1” is the loopback address of your QNAP.
My Roon runs on VM, on a different server to my QNAP.

I am just trying to mount an SMB share from my NAS. It shouldn’t be this hard! :frowning:

If you delete and recreate the share with the new password I don’t think roon is clever enough to know it is the same share so will reindex.

You can always “Clear library”

and than make a rescan.

PS: I don’t know anything about VM

Ok… fixed it with a super hack!

Mount a different temporary share from the NAS under Settings/Storage, preferably an empty folder (\\nas3\tempshare) Use new updated smb password to connected to this share.
This step is just to obtain the encoded password string later on!

SSH onto the core machine:
Edit the file as root: /var/roon/RoonServer/Database/Registry/Core/browse_shares
Copy the encoded password string from temporary share to the real Music share.

[{"cifsconfig":{"network_path":"\\\\nas3\\Music","username":"anasuser","password":"OLDPASSWORD==","workgroup":"WORKGROUP"}},{"cifsconfig":{"network_path":"\\\\nas3\\tempshare","username":"anasuser","password":"NEWPASSWORD==","workgroup":"WORKGROUP"}}]

Save file and restart the server!

Ugh… that was ugly!
Why is there no edit connection box in GUI?

Provided you are in the Edit function and at the “Choose music storage folder” screen, you can add the existing share anew and use the new password in the “Add Network Share” screen.

You will then see two instances of the network share in the left hand navigation pane of the “Choose music storage folder” screen, choose the new instance and you can now delete the old one.

This should not cause a reindex - because you are in the Edit function at all times.

I tried that.
I couldn’t add the same share twice. It said it was going to do it… But nothing happened!
Technically its not a new share… So I can see why it may fail?

Well, I’ve just done it for one of my existing shares, and it worked as I have described it. When you get to the stage of having added the share again so that it is listed twice, you have to select the new one and save it so that the old share can now be deleted…

I just tried it again…
It won’t mount it twice for me?

Well, I’m mounting a share on a Windows 11 desktop, and you’re using a VM on Ubuntu - perhaps that’s the difference?

Yes could be!
I wonder if it’s the same on a Rock or Nucleus?

Thanks for everyone’s help so far.

For clarification - my Core is on a ROCK/NUC, and I was mounting a shared folder from a Windows 11 desktop…

Ahh ok! It so could be a feature of me running Core on an Ubuntu vm?

Hmm…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.