Change User Credentials

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Synology NAS =>ROCK=>Chord MojoPoly

Description Of Issue

I needed to change my NAS password for some diagnostics. After doing so, Roon was no longer able to find my NAS. I did not see an easy way to update the password for an existing network share (is there one?), so I attempted to create a new network share using the same path as the old one, however, Roon didn’t take that as a valid network share.

The easiest solution would be for me to update my password so Roon can access my NAS. If that is not possible, how would I go about creating a new network share using the same path?

Here are a few screenshots-

My existing share path with my old credentials embedded somewhere:

I added the same share and username, but with the new password:

and the reply:

Thanks for the guidance.


Have you tried with an all lower case username?

Just tried lower case, and then most other permutations. I’m still getting the same response.

Roon has found my library :slight_smile:

I decided to restart Roon and then reboot ROCK (maybe the latter wasn’t necessary). After doing so, I was able to see the “x” to in order to delete the old folders and add the new one. After doing so, Roon was able to see my NAS and add the music folders.

All is well.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.