Check Qobuz and try again error

Roon Server Machine

Networking Gear & Setup Details

Connected Audio Devices

Weiss DAC 501
Roon nucleus Ethernet connection

Number of Tracks in Library


Description of Issue

I’m about done with Roon. For 3 weeks now anytime I try to play a playlist or album from my library it tells me streaming is unavailable and to check my Qobuz account and try again. It acts haywire quickly skipping through each track on the playlist, deciding they’re unavailable, and going to the next one. If Brinker long enough with rebooting, restarting, trying to play the playlist over and over, sometimes it’ll work. But I don’t get any value from having to spend 10 minutes every time I want to play a few songs. I’ve tried all the usual fixes I’ve found on here. It persists. I’ve spent 3 years curating all this stuff in Roon. Now it’s worthless.

I see from your previous posts that you have a Nucleus and an Eero mesh network.

Can you clarify a couple of things that would help the Support team to diagnose your issue further?

  • Do you have any local albums stored on your Nucleus? If so, do they play back normally, or are you seeing the same skipping issue?
  • Have you rebooted your Weiss DAC as well as your Nucleus?
  • Is the Nucleus connected via ethernet directly to your router, or is it connected to an Eero unit?

Hi @Lance_Smith ,

Can you please try to navigate to and try to play full tracks there and check if this works? The symptoms you describe are most often related to account issues such as a Qobuz account subscription expiring.

Honestly, that is one of the first things someone would try, and I did. That would not explain the issue I described as the tracks will play, just very unreliably and with that “streaming unavailable, check your Qobuz account’ very, very often. I have not used Roon the past couple of weeks and have not missed it yet. But at the moment I’m still paying so I’d like someone to have some genuine troubleshooting on this, as I’m sure it’s happening to others.



Ethernet. My Eero IS my router. And it has worked without this issue for over a years.

You clearly haven’t seen the cases where someone didn’t, or didn’t try rebooting, etc. And you hadn’t said that you did, so nobody could know, and of course they will ask that before [moderated] digging deep into the case.

1 Like

Hi @Lance_Smith ,

Can you please confirm what your streaming plan is listed as under your Qobuz profile webpage?

Do you use a promotional Qobuz press account or anything like that? Can you please let me know the exact local time + date + track when you next experience an issue? Once I have this info I can enable diagnostics mode for your account to try to see if we can gather more information regarding the issue.

It’s the Hi Fi Sublime+ plan.

Hi @Lance_Smith ,

I was reviewing some of my previous cases and I wanted to check in with you here, are you still seeing this issue or have you been able to resolve it?