Chord Hugo 2 + 2go + Roon

Yep. I bought my Mojo/Poly for just that purpose. When it didn’t work, I bought a Hugo2/2Go. I have to laugh. If I stay in one place, or wire the 2Go, they work pretty well. But that’s not what I bought them for.

Hmmm no stutters and skips with my 2Go when I’m 20 meters away.

I only have one wireless access point, located in the middle of the house. Enough to reach all rooms and outdoors.

1 Like

Don’t tell him. Useless. Guy thinks he’s the smartest kid in the room. Let it be so.
I’m seems to be John Snow and just like you – mine works within same perimeter around 70ish feet roughly (kicks through 2 walls, one of which is a carrying)

For anyone who is planning to buy this, rather than wishfully believing the couple of lucky owners here who somehow got working units, go check all the reports here and in other forums of 2go wifi problems. Or not. It’s your money.

You must be a super skilled network professional. I have one piece of Chord gear. It’s wired.

If you are happy with the 2go’s price for a wired streamer, I’m sure there are several bridge sellers ready to do business with you.

I have three Bryston BDPs and two MicroRendus. All are wired by ethernet cable.

My one piece of Chord gear is a Chord Qutest is a DAC. It is not designed to be networked. It’s connected via USB and SPDIF BNC connections. Even that bluetooth stuff is iffy in my book.

My statement about wired being better than wifi was a generic one.

I returned mine due to noise problems.

For more details on setup, impressions and wifi issues (many have them, many don’t),

Take a look here - Certifying Chord 2go

And lots of further reading here -

Just ignore all my experiences, I’m no expert on Wi-fi so I’m sure I must be as thick as a brick. it appears the most vocal carry the most opinion on here…


I have the Hugo2 and 2go now. It’s playing which is good but via Airplay on the iPad I’m getting a downsampling via Roon to 16 bit from 24bit for a master recording. The DAC is showing the Red colour when I hoped it would be Amber ? Any suggestions or is this a limitation of the Apple iPad ?..

The album a 176.4 master recording via Tidal. Thanks

Airplay is only capable of up to 16bit/44khz.
Since you’re streaming it from iPad to 2go via Airplay it’s been downsampled.
Add the ‘2go’ as an output in Roon – it had been certified recently - so that way you 2go would be able to get a signal from the server and play it as it is.

all done as others have said and very much appreciated.

btw - have you played around with the headphone cross feeds? i haven’t as yet

If you mean Roon, I use DSP ‘Audeze Presets’, particularly ‘LCD-X’ since I have one.
Quite pleased and I think it sounds better.
I don’t use Chord’s one, somebody else might – preferential

This thread (and others) had me scared, but I went ahead and got a 2go for my Hugo 2 anyway. The retailer had a good return policy, so I thought it was worth a try. Happy to report that wireless works flawlessly in my New York city high rise apartment. My network is through a Verizon Fios wifi 6 router (model G3100), and definitely not using any mesh devices in this 700 sq ft space. The convenience the 2go promises was just too good to not give it a shot, and I’m glad I did.


Another happy Hugo2go owner here, use it exclusively with Roon via WiFi, and it works great (if only they would get the promised Spotify Connect support up and running, then I’d have everything I want). Haven’t tried actually walking around the house with it playing, but it works flawlessly in every room of my house that I’ve tried (wifi provided by a Netgear Nighthawk R8000).


Hi ,
since the last update (build 764) my Roonready endpoints disappear from time to time. Especially the Chord2go endpoint works just for some seconds before it disappears…
After the update to 1.8 I had only problems with iOS endpoints, Roon ready endpoints worked perfect.
What can I do?
I never had any problems with Roon and the 2Go in 1.7 (I had to change to develop mode for a while…) but with 1.8…
Regards Michael
but since

Problem solved…I had to activate Bridgemode in my router…Amplifi must have changed something in their last update…

1 Like

Late joiner to this thread - I’m having issues with songs jumping in midtrack.

When I use any DSP settings, Roon (Tidal hifi) skips. Enough that it’s not useable.

In lossless, it seems to work ok.

For my core, I use a 2015 mbp hardwired to an Orbi mesh router. The endpoint is an hugo2/2go. When I use mconnect > hugo2/2go I have no issues. Network wifi speed at hugo2 location, (measured on an imac that’s on the same desk)is around 60 mbps. Network speed at source ranges from 95 to 400 measured via orbi app.

I like to play with DSP (eq for focal Stellia hp) and hope to use roon to feed multiple endpoints

but the instability in DSP mode is frustrating (I typically stay current with firmware updates on core and remotes + iPhone 12 pro max and reboot core.

I applaud everyone who has the knowledge and patience to micromanage every inch of the signal from modem to endpoint but I certainly don’t have the knowledge and I’m not sure I have the patience. I’d like to enjoy the music - not become an electronic engineer.

Is anyone else experiencing issues with ROON / Tidal / WiFi and DSP mode activated?? Any thoughts as to why? Is the demand on the core that much that it makes it useless?

Have you tested Hugo2+2go with an Ethernet cable instead of WiFi? WiFi on the 2go is temperamental, I sometimes have 2go WiFi skips from Roon local files even without DSP, and that’s with otherwise bulletproof WiFi. The interaction between Roon’s demanding RAAT protocol and 2go WiFi seems especially fragile.

I use DSP extensively with other (wired) Roon endpoints, no issues at all.

Since Roon without DSP, and mconnect, both work with the 2go/Hugo, it seems it’s the DSP.
So it depends on what you do with DSP.
If you do dramatic upsampling to much larger files, it may overload the WiFi (@Fernando_Pereira’s suggestion to try wired would answer that).

Otherwise I would guess the 2015 mbp is overloaded by the DSP processing. Look in the Signal Path (click on the star down by the play controls), the number at the top tells you how much of the compute capacity you use. (If there is no number, you are using a tiny fraction and that is not a problem.)