Chord Mojo and Hugo2 Roon Tested

I am using both Chord Hugo2 and Mojo in my systems. Both are supposedly Roon tested, which means they should have a line drawing of the device next to the audio zone. The Hugo2 does, while the Mojo has the generic speaker drawing. Is this the way it is supposed to be.

Is the device volume of these two devices supposed to be controllable from roon control? In the device settings of both I can toggle between fixed volume and device volume. If device volume is selected, both devices report 0 as max and 0 as minimum volume. If I open the little speaker icon at the bottom right, I see “volume control fixed”, even if device volume has been selected in device setup.

I tried Windows ASIO, WASAPI and Linux ALSA. Same result in each case.
Is there something off here?

The Mojo should be picked up. If not, go to the zone’s Device Setup and click on Not your device? Then press Identify this device and scroll down to Chord and choose the Mojo.

Thanks, @Martin_Webster
Just tried that. Up comes a list that only contains Blu MkII, Dave, Hugo2 and Qutest

Mojo seems to be missing.

I think this may have something to do with using ASIO. I’m on a Mac and my output is the Mojo; yours is ASIO which is why you’re seeing the generic icon.

You’re right. Switching to the WASAPI output solved the issue of the line drawing. Mojo is now recognized.
So Chord devices don’t seem to support device volume. With the Hugo2 it’s not really an issue, it has a remote. But the Mojo does not have a remote, so I have to get up to change the volume.

Your only option is to use DSP volume.

Thanks, I think, I’d rather get up and walk over to the Mojo …

@support Could you please look at this. Chord devices are recognized as long as WASAPI output is used, with ASIO output, only Blu MkII, Dave, Hugo2 and Qutest are recognized.

Me too. :slight_smile:

I can confirm that Chord Mojo does not support USB volume, it was one of the reasons I didnt buy it. I even sent an email to Chord support, and got some “It can’t be done” reply :slight_smile:

Its pretty strange that so few DACs has proper USB volume.

That’s why I keep mine at arm’s length:

Hello @jacobacci,

Thanks for the report. We’ve identified an error in our ASIO identification process for the Chord Mojo and corrected it accordingly. Could you try restarting your Roon Core and reporting if the Chord Mojo now appears when clicking the “Not your device?” button in Device Setup?


Too bad. USB volume can’t be that hard to implement. Apart from that I’m very happy with my Chord. And it sits only 8 feet from my sofa. Quite ok.

After a restart, all Chord devices now show up under ASIO:

Thanks and best regards

1 Like

I use Chord’s Poly + Mojo. I noticed you recognize other streamers like the Sonore micro and ultra Rendus. Can you detect the Poly?

(Also just noticed you have HifiBerry Digi+—nice! Strangely, the Mytek Brooklyn isn’t identified, only the Manhattan and Stereo 192.)