Chord Mojo downsampling to 352.8

Roon Core Machine

Windows 10 Pro 64bit, Intel NUC, Core i7-10710U @1.10GHz 1.61GHz, 64GB RAM

Networking Gear & Setup Details

Sky Modem, on Ethernet

Connected Audio Devices

External SSD

Number of Tracks in Library

1372 albums

Description of Issue

Roon output set to Chord Mojo. WASAPI Exclusive mode on. No active DSP. 705.6kHz tracks all downsampling to 352.8. I can’t understand why this is - the Mojo is connected via usual USB cable to appropriate port on the NUC. It plays to native sample rate on the Mojo (verified by colour change on the Mojo) on JRiver.

Any ideas? Is it a WASAPI thing? Thanks for any pointers :+1:

On my Win11 machine, foobar2000 is able to play 705.6kHz files with WASAPI exclusive. Roon on the other hand can’t open fail to access the device, works only with ASIO at that rate. Not sure why the difference in behavior from your system.

1 Like

Thanks for the feedback :+1:

Hey @James_Lambie,

I just wanted to check in and see if things have improved, or if we can still help :nerd_face:

Roon on Windows requires ASIO for Chord 7xx kHz.


Hi, thanks - no, still the same. I will try a different DAC later and see whether for some reason it might be a Chord Mojo thing.

Thanks for clarifying.

Hi, no further forward - I have no idea how to fix this.

I can’t fathom how to enable ASIO drivers on the Mojo in Windows. I’ve reinstalled the Windows ASIO drivers for the Mojo, removed then reinstalled the Mojo, reinstalled Roon but it still defaults to WASAPI. Looks like others have had the same problems. I’ve tried to follow the advice as best I can about setting up the device in Windows.

Other DACs are plug & play from the get go, but max out at 384/32. Don’t know if this is the issue.

IIRC the ASIO driver needed some additional work after install to setup and function in Windows - but it’s a long time since I had to do this.
If you go on to the HP of the Mojo, the ASIO driver is no longer offered there for download. Maybe a recent Windows update broke the ASIO driver? Maybe the license run out? Maybe the downloads got mixed up or streamlined with the recent release of the Mojo 2? You might want to contact Chord support and ask there? (they just renamed/updated the link since my last visit a long time ago)

UPDATE: On second thought, nowhere is compatibility to 705.6 kHz mentioned in the manual - can it be that this is the reason for Roon down-sampling (power of 2) to the next supported sample frequency?



Thanks for this.

It’s really strange. Both the Chord Mojo and a second DAC (a Topping EX5) top out on WASAPI at 382 in Roon running on Windows. Both DACs are capable of 752…

The same two DACs running on JRiver via Windows (again WASAPI) play up to 752. This is verified both by sample rate read out on the Topping DAC and the correct colour on the Mojo. You could say it’s an error, but this error would need to be consistent across both DACs on JRiver. Sample rate switching on JRiver across various sample files works as expected.

So, it is in theory possible that JRiver is wrong here, given the earlier mentions of 384 being the max via Windows WASAPI.

But if not, this is Roon’s issue.

If JRiver and foobar2000 work correctly with WASAPI, I think Roon has a problem. In my case, it can’t even open the device.

1 Like

I finally found the time to run some tests on my machine. Using Chord’s ASIO driver, the Mojo plays 705,6/768 kHz content over USB.

How does Roon default to WASAPI? I can see two entries for the Mojo in Settings|Audio in Roon, one for WASAPI and one for ASIO, on my Windows 7 system. What do you see?


As others already wrote, you need the (ASIO?) driver from Chord for 705.6/768 kHz playback. Without that driver the standard USB Audio Class 2 driver, which is limited to max 384 kHz playback, is used.

Can it be that Windows 10 is so different from Windows 7?

I see only the WASAPI option. I have deleted the existing ones and reinstalled the Mojo ASIO drivers I can find online. Still Roon doesn’t present me with the ASIO option you have pictured.

But this still doesn’t explain why neither of my DACs which work with 705 or higher work without downsampling in Roon, but apparently do via WASAPI in JRiver.

This I already explained to you: Without the drivers from the manufacturer, the standard USB Audio Class 2 driver is used which is limited to to max 384 kHz playback.

Feel free to post images of what you see in Settings|Audio in Roon, maybe someone is able to spot something crucial there.

Can this be the reason? Doesn’t this software come with some sorts of virtual soundcard? Can it be that this device is taking hold of the Chord Mojo driver and the driver for the Topping DAC, hiding it from Roon? Do you see a JRiver device instead in Roon’s Settings|Audio?
Maybe some JRiver users can comment on this?

In my case, I made sure no other apps were running besides Roon that could hold the device exclusively.

Thanks. It’s a Windows thing - I set up a Raspberry Pi running Roon Bridge on Audio Linux - and it plays bit perfect from Roon Core at 705/768 via WASAPI.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.