Chord mojo not showing

@support Until recently my Chord Mojo was showing its icon at the bottom of the screen. Now, although described as Chord Mojo, the icon is just a speaker.

I have tried to ‘identify device’ in Audio, but it neither recognises ‘Chord’ or ‘Mojo’ as options.

Still plays the music though, so it isn’t all bad.

Using a MacBook Pro 2017, OSX - 10.13.4, with the files on the hard drive.

Hello @James_Buchanan,

Does your “Identify this device” window look like this screenshot I have attached? How long ago did you notice this behavior?


Dear John,

Thank you for your reply.

It has been like this for at least a week or two. It’s a subtle thing so it might have been longer.

I should add that without ‘mojo’ in the box, there are no options below (as in your screen grab)

Go to Device Setup, Click ‘not your device’, re-identify your device and OK.

This should restore your icon.

Hello @James_Buchanan,

  1. Close the Roon application on your Mac
  2. Open “Finder”
  3. Go to the “Library” directory in your user folder. If you do not have “show hidden files” turned on, you can get to his folder by holding the “alt/option” button on your keyboard, clicking the “Go” item in your menu bar, and then selecting “Library”
  4. Navigate to the Roon folder located in your Library directory
  5. Open the folder named “Cache” inside your Roon folder
  6. Delete the file named “” and “” if you have that file as well

Once you have deleted these files, reopen Roon and note if you can see devices populate the “Find your device” screen like as shown in my screenshot.


Worked like a dream. Thank you.

A post was split to a new topic: Chord Mojo not appearing on SonicTransporter i5