Chord Mojo not working

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

I use a comcast hi speed router and my NUC is wired direct

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB into my denon AVR 4300H

Description Of Issue

Hi, need some help. I for the first time since the new Roon version came out I tried using my Chord Mojo but roon is not allowing me to use it. It works when plugged into my iPhone or laptop but Roon is not seeing it as part of the audio transport.

I read in here to reboot my Nucleus but that did not work. On the old platform Roon would show it as part of the streaming platform. Please advise as I am no expert.

I’m no expert and I don’t know how the nucleus works but on my Mac mini I had to reset it in Roon settings to ‘on’ for mojo/poly.

Mine doesn’t even see it, no idea.

What is the input to the Mojo?

Above you wrote:
“my NUC is wired direct and the USB into my denon AVR 4300H”

Where in this path is the Mojo?

I use it via usb to my mac book or Iphone with the phone adaptor. It always worked fine on old roon build. I can’t even find a way to add it to my devises in roon. Any thoughts?


As much as it pains me to ask, did you try another USB cable?

Also, when you use it with your Mac, without Roon, let’s say with Tidal, Qobuz, or other streaming service, do you get audio out of the Mojo?

BTW - I have two that I use in smaller, less used systems in our house. But they are connected to Sonore microRendu and UltraRendu as endpoints. They all seem to be working with the latest build. I know that’s no consolation, but at least we know that Roon recognizes them.

1 Like

Thank you for getting back to me, yes I did try another USB. I actually just got it to work on my macbook but still not on my iphone. It does work using a direct tidal hook up on my iphone and mac book.

Thanks again

Hello there.
I have the same thing my mojo doesn’t work with Roon.
But it works with Tidal or as a default output device.
Restarted my mac several times no changes, but I have a trial Roon.
Can it be the case?
Thank you.

@David_Newman - Great news on your Mac success. Unfortunately I have no experience with phones as an endpoint. But, I do have one question: Are you certain that your phone is on wifi when you are attempting to use the Mojo with it?

@Andrei_Maksimov - I don’t believe there’s a difference between fully licensed Roon and Trail Roon. You’ll need to get Support to work with you on that.

Good luck.

Thank you

My mojopoly works even with the latest roon update fine. Any change if you reinstall the chord app?

My iPhone XS also no longer recognises the Mojo when connected via the apple adapter. It just doesn’t show up under the Audio devices section.

The OP did not mention Poly, MojoPoly still works without issue.

I also connected the Mojo to my MacPro where it showed up as a connected device but Roon did not recognise it as Chord Mojo and I had to search for the Mojo icon.

Roon Core on ROCK.