Chord Poly Support

Managed support thread for Chord Poly issues

1 Like

Having upgraded the poly to 2.0 it Initially working with Roon however no longer works (it can be seen as an end point but will not play). Putting the poly into other will allow it to play Roon via airplay.

I have the same exact issue. the days immediately after the poly firmware update, poly worked flawlessly in roon ready mode. mine started for about a week from now. poly is recognized as an audio zone, but music files cannot be played, even when I add them first to the queue.

I also have the same issue.
I’m on the latest version of all software.
Otherwise Roon is working with all other devices.

I have the exact same issue. Poly was working, now Roon can see it but when you tap play nothing happens :frowning:

Hello @Nick_Hillier, @ted_anthony_tobias_k, @Mike-D, and @Keith_Marsh,

We appreciate your patience while we work with Chord Electronics to investigate this issue some Chord Poly users are seeing when using Roon Ready streaming.

To help us isolate what could be causing the behavior to occur, we would like to enable advanced diagnostics on affected users’ accounts so that we can have the technical team take a look at the Roon and device level logging information.

It would be helpful for us if each of you could attempt playback to the device and note what the current local time is when you make the attempt. This will help zero in on the relevant logging and hopefully assist in getting this issue resolved as quickly as possible.


Hi John,

I have the same issue as the others described. After updating poly’s sw to vers. 2.0 everything was fine. After some days the play button shows no response. Poly shows up as an audio device and audio settings appear to work as normal. Maybe it come with the installation of latest Roon update.

Pressed the Play button at 21:21:00 29.04. local time.

  • Uwe

Attempted to play at 21:30 UK time today

22:22 uk time

Playing now at 0659 local time Philippines

the problem seemed to have resolved in my Poly-Roon setup when i did a Re-RUN of the WIZARD under DEVICE SETTINGS on GoFigure using an iOs device. i have noticed that it wasn’t only in Roon in which Poly couldn’t be recognised as a DLNA renderer, but can be seen as an airplay device. also, i have noticed that with Bubble UpNp, Mconnect, HiFy, and other android streaming apps, Poly could be seen as a SERVER but NOT as a DLNA RENDERER. after a re-run of the GoFigure wizard, Roon was able to recognise Poly again as a renderer with bit perfect streaming, as well as with the aforementioned android apps. i hope this can help others in resolving their issue with Roon and Poly.

NOTE: when I did the re-run of the wizard, I did not change anything from my Poly’s Settings.

Good day, everyone! Running Roon 1.6 on Windows 10. Roon sees Poly as an AirPlay device but does not see it in Roon mode. Any ideas?

When I tried this, it didn’t work but I started seeing error messages from Roon saying, too many attempts failed for playback

Hello All,

Our QA team is combing over the logs at the moment, thanks to everyone who gave a helping hand to get them looking nice and orderly.

As the QA team continues to investigate, another diagnostic I would suggest performing if you have not already is a restart of the Roon Core.

I will be sure to pass along any relevant information as we continue to look into this. We appreciate your patience and we hope to have more to share soon.



My poly was fine until I updated it 2.0. I just tried using the Poly on Roon at 8:45 PM.

I was waiting to update Roon to eliminate the slow search issues. Therefore, I have tried with both 1.5 & 1.6. I updated to 1.6 tonight in hopes that would alleviate the inability to use it with Roon, still no joy.

Restart core again and no change in behaviour

same here. today the problem is back to the way it was originally. its no longer saying “too many attempts” or anything, just seemingly non responsive to ‘play’

Hmmm… Mine works now somehow…

mine has had no problems since I re-run the GoFigure Wizard.