Chord Qutest/Rasberry Pi not working with Curious cable

Cross Posting this over here in the Qutest thread, since more qutest users may have some ideas and also may understand the use of a high end USB (or maybe not) but I already bought the cable and I wish to make it work!

I just received a Chord Qutest, and having read suggestions I picked up a Curious USB cable to go with it. I’m trying to use my Rasberry Pi as the streamer going into the Qutest via the Curious USB, however whenever I plug in the Curious USB it won’t show up as a device in Roon most of the time. Occasionally it shows up momentarily but then has difficulty connecting. However, when I use the USB that came with the Qutest it works fine. Additionally, if I plug the Curious into my MacBook pro and then to the Qutest, the Qutest shows up immediately, so it’s something to with the Rasberry Pi in the chain.

Any ideas?

Actually, I think the issue may be something other than cable. Messing with it more now, and it’s intermittent at best with the standard cable. After, a series of restarting sometimes it shows up in Roon and sometimes not. On a Ras Pi 4 with RopieeeXL.

If I plug in my Schiit Modi to the Ras Pi it immediately shows up.

Does the Qutest work with a standard USB cable?

It works more than it does with the Curious USB, however it’s still not that consistent. It often won’t show up at all and I have to restart the Rasberry Pi, sometimes after a restart it shows up and sometimes it doesn’t. Similar results with multiple standard USB chords I have including the one included with the Qutest. The Curious seems to be the hardest to get to work though it has also connected sometimes too. So a strangely intermediate problem. All cables work fine when plugged into my computer and then into the qutest.

I owned a Qutest a few months back.
I had zero problems with any USB cable I tried connecting to a Sonore Ultrarendu.
This included el cheapo printer cable, Audioquest Carbon, Audioquest Diamond, Pangea, Straight Wire etc.

I think there maybe a problem with the Pi4?

Now that I’ve seen this duplicate thread/posting I have to agree it seems a fault with the RPi. Have you tried the other USB ports?

I have been rotating USB ports and haven’t found any one to consistently work better than another. Somewhere I have another Rasberry Pi I could try but I’m not sure where it is. (I just moved a few months ago and bought another one because I couldn’t find this one! ) Anything else I should try with the Pi?

Also, strangely it does work right away every time when plugged into Schiit Modi.

I’d say a fault PCB where the USBs connect to the RPi. When all connected, apply a little pressure to the top of the USB housing.

I mentioned power supply before, is it a lower powered brick.

It’s the standard Rasberry Pi 5v

I forget what the output specs are. I know it’s 5V, but what’s the max Amps. I’d suggest a power brick that’ll have upwards of 2Amps. It shouldn’t be as USB ports and cables have a specific standard to meet. I’m not familiar with the Curious cable, but it may struggle with the standard power brick.

If you could find your other RPi or borrow another, I’m interested to see what’s causing you the issue.

Can you log on to the pi via ssh or terminal?
Type:
dmesg
Do you see anything in the dmesg output like “under voltage”

I’ve seen the cheap pi power supplies act up.
The pi should have a supply that gives 5v 3a.

Could not find anything specific to voltage. But I did notice that with the regular cable it sees the qutest:

New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2.941909] usb 1-1.2: Product: Qutest
[ 2.941932] usb 1-1.2: Manufacturer: Chord Electronics Ltd
[ 2.941956] usb 1-1.2: SerialNumber: 413-001
[ 3.070998] systemd[1]: System time before build time, advancing clock.
[ 3.153679] NET: Registered protocol family 10
[ 3.154444] Segment Routing with IPv6
[ 3.188188] systemd[1]: systemd 247.2-1-arch running in system mode. (+PAM +AUDIT -SELINUX -IMA -APPARMOR +SMACK -SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +ZSTD +SECCOMP +BLKID +ELFUTILS +KMOD +IDN2 -IDN +PCRE2 default-hierarchy=hybrid)

And with the Curious cable I get this:

] random: 7 urandom warning(s) missed due to ratelimiting
[ 5.831532] usb 1-1-port2: Cannot enable. Maybe the USB cable is bad?
[ 6.741447] usb 1-1-port2: Cannot enable. Maybe the USB cable is bad?
[ 6.742020] usb 1-1-port2: unable to enumerate USB device
[ 10.877060] IPv6: ADDRCONF(NETDEV_CHANGE): wifi0: link becomes ready
[ 33.290172] sched: RT throttling activated

Definitely seeming like it’s the cable. In the other thread, someone posted a response from Curious stating that this cable may not work with RasPi. I’ve also reached out to Curious and I’ll let everyone know what they say. Was considering trying a different OS, maybe DietPi or VitOS. Though, after seeing this in the ssh, I’m not real optimistic and may not waste my time as I have RoPieeeXL working just as I’d like.

1 Like

This is a real good case for high end " boutique" cables… Not!

Be very interested in what Curious Cables have to say in this matter.

1 Like

You are getting kernel messages about a cable, quite telling and pretty clear. Get rid of the cable, move on.

Try a different usb cable, reboot, ssh in, and run:

dmesg | grep -i usb

See what the kernel has to say about the state of usb after a reboot and different cable.

1 Like

Already moved on, so I really don’t want to go back in and check the SSH since it’s working. I’ll stick with the stock cable for now, though I did notice a quality difference when playing directly through my MacBook Pro, which does work without issue using the Curious cable. I’ll maybe slap a Regen ISO or something to my Ras Pi to clean up the signal a bit and leave it alone.

2 Likes

Got yah. I’ll make sure to stay away from Curious. I mean, one huge pile of audio devices run some type of linux. How did they mess that cable up is a good question.

I chose it because it seemed the overwhelming favorite from the Qutest headfi thread. Darko audio also rated it very well, but if it doesn’t work with my system it’s not much use!

2 Likes

I wouldn’t put much into what what folks like Darko or Beekhuyzen have say… I would ohm the cable to see if there is any voodoo (read resistance) embedded…

2 Likes

You have to love some of these Curious reviews:

“…the new Curious Evolved cable has a sweeter and richer delivery with a more organic and free-flowing perspective”

But is it really organic? And its perspective may be free-flowing, but what, may I ask, is its core philosophy? And while we’re at it, what are its spiritual beliefs?

It is Australian. Perhaps it it isn’t comfortable in the Northern Hemisphere?

3 Likes

I have a curious cable plugged into my qutest and works great. Source is a stack link 2, which is a glorified Pi.