Chromecast Audio devices not showing as available


I’ve suddenly lost the ability to stream to CCA devices - I have 5 of these scattered throughout my house, and Roon is showing “No audio device found” - but I can see them under “Manage audio devices”!
I’ve tried restarting both the client (MacOS desktop app), and the server (Linux NUC machine) - and it’s made no difference. I can cast to the devices from elsewhere, like Spotify, so it’s not an issue with the CCA, but rather the integration with Roon. Please help?

Hi @Andrew_Stangl
Have you also tried briefly unplugging the Chromecasts, rebooting the router with all network components and restarting your remote device?

I’ve remotely rebooted chromecasts via the Google Home app, and that’s made no difference - as a final step will attempt to restart the router - I’ve got a Ubiquiti UDM SE, so it’s controlling a lot of APs, and rebooting will reset the entire house, have been avoiding doing that

Are your Chromecast devices available as endpoints under the Roon Settings → Audio tab, and are they enabled? Can you post a screenshot of the Audio tab? Where do you see the “Manage audio devices” option?

Yes, I see all Chromecast devices there, and I can also cast to those devices from other apps

But as you can see at the bottom of the screenshot - “No audio devices found” :thinking:

I’ve tried restarting the router this morning, as well as all connected devices, still no luck.
I wonder if something changed on the Chromecast side, that needs an update in Roon? there have been two updates to Roon since this issue started, I wonder if anyone else is experiencing the same issue

I only have one Chromecast capable device at the moment. It’s my Cambridge CXNv2. I’ve enabled Chromecast and it plays successfully here.

I wonder if this is a Firewall issue on the Mac? I admit it seems a little unlikely for your setup, but still…

Thanks for your reply, but I did consider that - unfortunately the firewall is already inactive:

Interestingly, it looks like there are some devices on the network that are being detected as endpoints, but these are Airplay devices (an Onkyo AVR in particular) - even odder, is that there are two other Denon AVRs that are not being detected (and were being detected previously)

Some more information: if I disable and re-enable the chomecast devices that show up under Audio in Roon client settings … I hear the Chromecast anouncement sound on speakers attached to the chromecast in question!! so it’s definitely able to see the chromecast, it’s just not coming up under available devices to stream to :-/

This appears to have resolved itself - I made no further changes, but suddenly both the missing CCA devices showed up, as well as the missing Airtunes devices. No idea what happened, or what else changed behind the scenes/in the background. Oh well, just another glitch in the matrix :person_shrugging:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.