Chromecast doesn't work with my new computer

Hi Roon,
Now I have given up and hope instead that you on “Roon” can help me to get my new computer with WinDos11 Home to work with “roon” as well as my old computer with WinDos10 did with Chromecast…

My computer:
Device name TOBBE DESKTOP.
Processor AMD Ryzen 7 4700U with Radeon Graphics 2.00 GHz.
Installed RAM 16.0 GB (15.4 GB can be used).
Device ID E363312C-7FBE-494A-BD04-5E89E15B47A1.
Product ID 00325-96696-33157-AAOEM.
System type 64-bit operating system, x64-based processor.
Pen and touch screen Pen or touch input is not available for this monitor.

Edition Windows 11 Home.
Version 21H2.
Installed 2021- 11- 25.
OS version 22000.434.
Interface Interface package for Windows functions

This is the situation (and excuse me for me the google translation :wink:) …

I am super happy with roon and the reason I bought a life time license is because I LOVE MUSIC … but now I have unfortunately been forced to reduce the use of “roon” as my primary music streaming service as I now have problems getting it to work with my “Anthem AVM 70”… it is promised that Anthem will update the new generation of MRX & AVM devices with Roon soon, but what “soon” means there are probably divided opinions about.

While waiting for Anthem’s promised update to implement the “roon”, I’m referred to streaming via the device’s built-in Chromecast feature. This has worked flawlessly until I replaced my computer and got rid of the old one. At first, I thought this “Roon / Anthem” problem was related to my Anthem AVM 70, so I’ve had to go back to streaming from Tidal directly to Anthem’s chromecast. Tidal, Spotify, YouTube Music and "all other” audio related sounds that can be casted via chromecast from my new computer to my Anthem AVM 70 works without any problems, but unfortunately not “roon” anymore.

So, what to do to fix the problem temporarily … ran away and bought me a “roon tested” Google Chromecast “4th gen" … and guess what … “roon” still does not work… but then I did realize that everything else works without problems. So there fell my theory that this was an isolated problem to Anthem’s device. After further tests it turns out that all equipment with chromecast has exactly the same problem with my new HP computer.

Contact the “new owner” to my old computer, borrow it back for a new test, and guess … “roon” works just fine with every single chromecast device I can get to do a test with… including my AVM 70 !!!

So, while waiting for Anthem to fix their problems with getting “roon” and “Spotify connect” to work, (which I seriously start to believe that they will never will get to work with regards to the time it seems to take and that you do not get any kind of answer from anyone when the question is asked … more than silence !!!) I would kindly like to beg “roon” for help to get “roon” to work with my “new nice expensive laptop” with the “latest operating systems” and the “latest updates” before I give up and sell everything on the used market …

I’m really not an expert on computers and the once I know, and for sure do know more than me, don’t know either where the problem may be. So, I really start to give up…

Anyway… here’s what happens when I try to cast “roon” with my new beautiful computer to a device with Chromecast built in:

  • I open Roon on my nice HP computer with OS WinDos11 Home

  • Selects [Settings]> [Audio]

  • Then I see all available devices that can be activated

  • I choose one of the chromecast devices

  • When I “press” [Enable] on the screen to select one of the chromecast device, I hear a “ping” from the speakers

  • The [Enable] push button, for the chromecast device, does not switch to the “settings symbol” but remains as a [Enable] push button !!!

When I do the exact same procedure with my old computer, the [Enable] push button disappears immediately and the entire field showing that the chromecast device switches over to an enabled audio device and I can do the settings. Then the activated chromecast device appears as a selectable device when you press the “speaker icon”. I select the device from the listed units and start casting to the selected chromecast device. The music starts without any problems… easy, isn’t it :wink:

Please, help me to understand what it is I need to change on my computer to get “roon” working with chromecast… while waiting for Anthem to successfully implement Roon in their devices… or if I should just get rid of it and find an old computer as works with “roon”.

Thanks in advance !!!

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

What kind of computer was the old one, the one that works?

If you search for “can’t enable chromecast” in the forum, you’ll see a lot of reports. Here’s one fellow who solved his problem. As this shows up on the new computer, but not on the old, maybe it’s the same problem you are having.

Hi Bill,
Thank you for taking the time for me. Yesterday I also sent the question regarding my chroecast problem to Roon Support and I hope that they might be able to find out he an idea of ​​where the problem may be.
But if you have some time left for me you can see spc. below to both my old huge laptop and my new little flexible laptop with a fantastic screen;)

  • The old computer that works without problems with “roon” …

Computer HP ZBook 17 G3
Processor Intel (R) Xeon (R) CPU E3-1535M v5 @ 2.90GHz 2.90 GHz
Installed RAM 16.0 GB
Device ID C95EF84B-04A5-49A2-B5AE-B4A7D5F9AD93
Product ID 00342-50484-73128-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch screen Pen or touch input is not available for this monitor.

Edition Windows 10 Pro
Version 21H1
Installed 2020- 11-03
OS version 19043.1466
Interface Windows Feature Experience Pack 120.2212.3920.0

  • The new computer that does not “enable” the chromcaste devices:

Computer HP ENVY x360 13-ay0xxx
Processor AMD Ryzen 7 4700U with Radeon Graphics 2.00 GHz
Installed RAM 16.0 GB (15.4 GB can be used)
Device ID E363312C-7FBE-494A-BD04-5E89E15B47A1
Product ID 00325-96696-33157-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch screen Pen or touch input is not available for this monitor

Edition Windows 11 Home
Version 21H2
Installed 2021- 11- 25
OS version 22000.434
Interface Interface package for Windows functions 1000.22000.434.0

I will immediately go out and search for your tips and see if there is anyone who has happened to the same thing as me … and if you have an idea based on computer specification, I would be more than happy to hear from you.

Thanks for now :slightly_smiling_face:

Hi Again Bill,


After your tip I saw that it could be the firewall … so I switch it of and guess … “roon” works with all my chromecast units. And then I activate the firewall again … and the “roon” stops.
I use “McAfee” as my “defender” for my new computer and after some support from them we find out that I have to change some settings for the home network to alow “roon” to be able to be allowed as a approved ““thing”” in my network … but it’s only “roon” which has this issue to cast to chromecast. Tidal, Sotify, YouTube and so on has not the same problem :wink:

…but now “roon” works perfect with my new computer … so thanks for your tip and link to one of the “roon chromecast problem” topics.

:sunglasses: :+1:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.