Can´t enable chromecast devices

Roon Core Machine

Windows 11 on Notebook Acer Swift 5, i5-1135G7, 16 GB RAM, tried LAN and WLAN with this issue

Networking Gear & Setup Details

Vodafone Station, some Chromecasts are connected via WiFi, one via LAN and some via PowerLan

Connected Audio Devices

4 Chromecast Audio (2 via WLAN, 1 LAN, 1 PowerLAN)
1 Chromecast 2nd Gen, (WLAN)
1 Chromecast Ultra (WLAN)
1 Google Home Mini (WLAN)
1 Raumfeld Connector, Chromecast Build-In (PowerLAN)

Number of Tracks in Library

11621 Tracks

Description of Issue

I am not able to enable the Chromecasts.
When going to “roon, Settings, Audio” every chromecast (except for the Raumfeld CC Build-In) is listed.
If I click on “Enable” of a Chromecast Audio => nothing happens
If I click on “Enable” of a HDMI Chromecast => the Roon app tries to start on the TV screen but circle keeps spinng endlessly
If I click on “Enable” of the Google Home Mini => a few seconds later a sound is heared

But nothing happens to the Enable Button and I´m not able to give the device a name.

So I´d love to use roon, but I´m not able to find other speakers than that of my notebook.
Maybe I should try it again in a few months and cancel my subscription.
There are 5 free days left to try out.

But maybe someone can help.

Have a nice evening,


I solved the problem.
On installation windows asks if roon should be allowed for public or private network.
The default is public and on first installation I changed it to private.

This was the mistake and I was not able to enable the chromecast devices (I have only those).

Uninstallation and a new installation was not succesful because Windows remembered this adjustment to private network.
So I changed the settings in the “windows defender firewall” menu concerning apps from privat to public and now everything works.

Also, I was not succesful to connect the android app to the windows roon core before this adjustment. Now this is also working.

So at the moment everything is working fine.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.