Chromecast Screensaver Activating

Roon Core Machine

Intel NUC10, i7, 32GB, 1TB Samsung 980Pro SSD

Networking Gear & Setup Details

Netgear 510 Multi-GB Switch - Wired Ethernet

Connected Audio Devices

Ropieee on Raspberry Pi 4B to Chord MScalar/DAVE
Chromecast Puck to HDMI on my TV

Number of Tracks in Library

I mostly stream from Tidal- very small Library

Description of Issue

I’m using the display to Chromecast to display the album information on my TV. I haven’t changed anything and its been working great for months. Recently, Chromecast goes to screensaver every 15 minutes or so. I went through all the settings on the Chromecast and can’t find anything to disable to keep this from happening. Any thoughts?

Hey @Andrew_Embury,

We’re so sorry this happened over the weekend. We’d love to help.

I wonder, would you be able to factory reset your Chromecast device?

https://support.google.com/chromecast/answer/6254654

Thank you. I performed a full reset as suggested. No change in behavior. It goes to screensaver after 10-15 minutes. Hitting the back button on the Chromecast remote immediately returns it to the Roon Display and the lyrics fully synced.

This just started happening to me, but only on my Chromecast with Google TV. It’s not happening on any of my other Chromecasts.

Hey @Andrew_Embury and @Vincent_Kennedy,

I’ve taken this specific use case to our team, and we were wondering if you’d be able to try one more step.

If you feel comfortable going into dev mode, could you please enable the stay awake function? This is more of a long term fix.

The second one would be to open the Google Home App, select the Chromecast device and go to Settings. Scroll all the way down and tap on ambient mode to disable it.

Thanks in advance :pray:

@beka - Dev mode on what device?

I don’t see anything that disables Ambient mode:

Hey @Vincent_Kennedy,

Disabling ambient mode or enabling stay awake in dev mode is not something directly related to Roon — it is Chromecast specific. Searching online about this it seems to affect other streaming apps like Twitch or Youtube.

Disabling ambient mode is explained below, in this Chromecast Help page:

https://support.google.com/chromecast/answer/6080931?hl=en

Finally, it would be dev mode for the device. It should be found in settings - system - developer options - stay awake. The instructions here might be of help:

I totally forgot that there’s dev options on the Google TV devices. I run it on my phone and tablet.

Space…the final frontier.

I’ve enable dev options and enabled “stay awake”. I am testing now.

1 Like

Great solution - worked here - I didn’t know there was a hidden menu.

1 Like

It’s been nearly 3 hours straight and no issues. This change resolved my issue.

Well done @beka !!!

1 Like

Hey @Vincent_Kennedy,

I’m so glad the solution worked for you!

I wish I could take the credit :blush:. It was my colleague, @Wes who discovered it. I just passed it along.

Still, I’m joining the celebration :partying_face:

3 Likes

Thanks @Wes! I really appreciate it.

I really like this casting of Now Playing. It’s especially great when the Radio or a Playlist is streaming.

Take care!
Vince

4 Likes

You are most welcome!

2 Likes

Worked for me as well, but…

The Spotify and Qoboz apps when casting do not need this fix so there must be some setting their developers add to their app code. Please have your devs pester the team from Qoboz and ask how they did it.

Or ask Mr Google

3 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.