Classical compositions: wrong movement order

Roon Core Machine

Roon core: QNAP NAS (TVS-471).
RAM: 16 GB
CPU: Intel Core i3-4150 CPU @ 3.50GHz

Networking Gear & Setup Details

Router: ASUS RT-AX88U
Ethernet: Raspberry Pi [Pecan PI RoPieeeXL]

Connected Audio Devices

Collection size: about 28000 tracks.

Library Size

Description of Issue

I’ve noticed that, when I play a classical composition, the movement order does not always correspond to the normal order.
The playing order might be different for different versions of a same composition, but the (wrong) order is always the same for one particular version.

For example, I have three versions of the Beethoven string quartet op. 131: two by the Tokyo String Quartet, and one by the Artemis Quartet.

When I play the version of the Tokyo String Quartet (1993), the movement order is:
'5. Presto
'7. Allegro
'3. Allegro moderato - Adagio
'1. Adagio ma non troppo e molto
'2. Allegro molto vivace
'6. Adagio quasi un poco andante
'4. Andante ma non troppo e molto

Version of the same composition with the other Tokyo String Quartet (2010):
'5. Presto
'7. Allegro
'1. Adagio ma non troppo e molto
'2. Allegro molto vivace
'6. Adagio quasi un poco andante
'4. Andante ma non troppo e molto
'3. Allegro moderato - Adagio

And for the Artemis Quartet version, here is what I got:
'1. Adagio ma non troppo e molto
'5. Presto
'6. Adagio quasi un poco andante
'2. Allegro molto vivace
'3. Allegro moderato - Adagio
'4. Andante ma non troppo e molto
'7. Allegro

I’ve checked the file tags, everything is correct. And toggle shuffle is off.
I’ve observed this problem with other compositions as well.
And of course, this problem does not occur when I play the composition from the Album view window (where the composition parts are played in their normal order).

Any idea?

Thanks,
Thierry

Thanks for the detailed explanation @Thierry_M. Would you mind sharing some screenshots as you’re playing these examples?

For example, please show where you’re playing from that gives you these tracks out of order, and take a screenshot of the track order for each different album, then please take a screenshot of the tracks as you see them when played from the Album view.

Also, let me clarify - these are all examples from your local library?

Hi Kristen
I only have a local library (no Tidal, no Qobuz).
Here are some screenshots:


This one shows the three versions of the Beethoven quartet op. 131 that I have in my library.


I select the second one and click on “Play now”.


The first movement that is played is the fifth one: 5. Presto


And the next one is the seventh: 7. Allegro


The Queue screen which shows that the Toggle shuffle is off.


The “View parts” screen, showing the wrong movement order.


And finally, the Album view, showing the “normal” track order.

Thanks for your help.
Thierry

Here are screenshots of the track order of the two other versions:


Hello @Thierry_M,

Thank you so much for sharing all the information that Kirsten has requested. You’ve now also illustrated what you clearly explained in your post. We appreciate it.

Could you please send us one more screenshot of your Import Settings (in Settings → Library), especially the part dealing with Metadata Preferences for Albums (see screenshot below as an example:

Thanks a whole lot :pray:

Hi @rebeka
Sorry for this late reaction, but I was not at home in the last few days.
Here is the screenshot:


If I set the Composition/Part grouping option to “Prefer file”, nothing changes.

Thanks,
Thierry

Thank you @Thierry_M for following up. Anytime you can, we’re happy to hear back from you.

I’m taking this to our technical team so they can share their suggestion in solving this.

Please, stay tuned (while keeping in mind that we all work M-F :nerd_face: )

Hi @Thierry_M

I think we’ll need to reach out to our metadata provider about this one. Can you share a screenshot of an album from your library where this issue appears?

You can also use WORK and PART tags for local files to manually adjust this.

Hi @dylan
Here are screenshots of two albums (among many others):


If I play the piano concerto from the Composition window, it starts with the second movement (Adagio):

And here are the WORK and PART tags for this album:

Another example:



Thanks,
Thierry

Hi @support

Still have the same problem with the movement order for classical compositions: when played from the composition window, the movement order is not what it should be.

I observe this problem not for all compositions, but for a majority of them.

Here are a few screenshots of the “View parts…” window for different compositions:










Is this a bug? Or is there something that I miss?

Thanks,
Thierry

Hello @Thierry_M ,

We’re sorry to hear that classical performances in your local library are playing out of order. That can certainly be disorienting!

Please see this article from our help center, specifically the section on tagging multi-part works, for details on how to correct this.

Hi @jamie

Thank you for your reply.
I can assure you that my files are carefully tagged.
Here’s an example:
When I play (from the Recordings window) the Dvorak’s Cello Concerto in B minor by Alisa Weilerstein, it starts with the second movement.


And here are the file tags for this album, as shown by mp3tag:

Is there something wrong in my file tags?

Thank you
Thierry