Client plays on "wrong" mac / wrong system output

Roon Core Machine

Mac mini / Apple M1 / 8 GB / Sonoma 14.0
Roon 2.0 (1311)

Networking Gear & Setup Details

Amplifi router - ethernet cables. No VPN

Connected Audio Devices

1: Mac Studio / Apple M1 Max / Sonoma 14.0 / networked (ethernet)
Roon 2.0 (1311)

2: Bryston BDA 3.14

Number of Tracks in Library


Description of Issue

If I start the client on my Mac Studio and select “System Output” after activating it on “This mac” under Audio setting, the sound is played on the roon core mac (MacMini) rather than the client mac (MacStudio). However, if I open up a “share screen” session on my client mac (MacStudio) so that I can see the core mac (macMini), the sound is suddenly transferred to the client mac (MacStudio). If I close the shared screen, the sound is transferred back to the core mac.
I have of course checked that the “sound” settings for both mac’s are correct. I have updated with the latest software. And I have restartet both machines.

No problem with the Bryston client - only the mac client.

Any suggestions?

Hope support at Roon can take a look at this. I have re-installed all software with no luck. It seems that the software gets confused when there are two mac’s - one running as a core and another running as a client / audiozone. The concept “This mac” seems to shift between the two.
When I open the share screen to the mac running the core - “This Mac” seems to be the mac running as a core. I can either enable “System output” or CoreAudio, but not both on the same time. However, if I open the roon client on the mac running as audio zone, “This Mac” seems to be the client. If I change the setting on the Client “This Mac”, the settings also change for the core “This Mac”. I can provide screen dumps or other details if necessary. It has worked before - but not after “upgrading” my core to an M1 chip and updating the software to latest version

@Petter_Hurlen, Roon support does not work over the weekend, they will see this in their queue when they return to the office Monday.

Yes, I believe posting some screenshots would be helpful, especially with the shared screen feature. I have run multiple Macs on Roon without any issues, but with Apple’s recent OS updates enabling AirPlay casting to any Apple device with AirPlay I am wondering if the share screen feature may be transferring some control options in unintended ways.

This is a screenshot from M1X Studio Mac intended to be a client. There is a reference to “This mac”. It is however not to the M1X Studio Mac intended to be the client, but to the Mac mini running the Roon core. When I click play - it is played on the Mac mini. Unsuere if CoreAudio refers to the Mac Core audio or the Roon core, but it is anyway played on the Mac mini loudspeaker.

This is also a screenshot form the M1X Studio. This time, I have opened up screen sharing with the Mac mini running the Roon core. The client softare has not changed. However, in the screen sharing, “This mac” refers to the same mac - at least the setting is the same. If I now enter play, the sound is played on the M1X Studio. Opening the screen sharing seems to have transferred something. If I close the screen sharing, the sound is again played on the Mac mini internal loudspeaker.

My final screendump.
This is from an iPad pro - running the same Roon client software. If I hit play here, and the share screen is opened, the music will play on the M1X studio. If I close the schared screen, the sound is transferred back to the Mac mini. (and - yes, I have too many Apple TV’s).
It seems to me that on this screen dump, the top listing - This tablet - refers to the tablet running the client. Similarly, on the Mac mini running the core, “This mac” refers to the Mac mini. However, in the M1X Studio client window, the M1X Studio is not recognised, but instead “This mac” refers to the Mac mini running the core. The M1X studio only turns up under “Other network devices” to be connected via AirPlay, and as an Apple TV (!),not as a client running the native Roon software.
Hopes this clarifies the challenge - and presumably there is a very easy fix…

Sounds like this might be the same Sonoma issue as reported here:

1 Like

Thank you @Rockhound, it appears in the thread you posted that screen sharing may be related to the issue.

@Petter_Hurlen, per @Rockhound’s linked post, the OP there disabled screen sharing and the issue went away. Have you tried this approach?

1 Like

Thanks. It may definitely be the same problem, but the behaviour is different, and the suggested approaches don’t work for me. Actually, it is the screen sharing that establishes the correct behaviour, and turning screen sharing off results in the in-correct behaviour.
It seems that the Roon core software on the Mac Mini do not recognise the Roon client software on the M1X studio. It recognises the client on iPad, and it recognises the Roon ready dac - but it categorises the M1X studio with the Roon client as an AirPlay unit, like my fridge.
I do not use USB, all is on cabled network.

Hi @Petter_Hurlen,
Thank you for taking the time to write to us. This is likely a known issue with Sonoma changing the Core Audio to any available thread. Here are some steps you can try to resolve your issue.

  1. Try RAAT server refresh on your core device
  2. Review the audio midi setup from system preferences and reproduce the issue, does the core audio also change to the other device?
  3. We can review a fresh set of core diagnostics - if you’d like, we can enable diagnostics mode for your account, which will send over a set of logs from your Core device automatically, and then upload them to our servers for analysis.

Thanks. Tried both - did not work. Or - actually - the trick with the screensharing do not work any more. Since last time, I have updated to Sonoma 14.1
My impression is that the Roon client software do not recognise the mac it is running on, but instead believes it is the mac running the Roon core. The midi/audio settings in the mac running the core and the Roon software is identical - both on client and core Roon software. The midi/audio settings on the mac running the client is very different. None of these are recognised by the client software. I have made a screendump of it all - to the left you see a screen sharing from the mac running the core. It shows both the soud setting / alternatives and the Roon core window - including alternatives for source. On the right you see the same for theRoon client on a separate mac. As you can see, the audio settings are identical to the core, and noen of the alternatives from the client is available. Logging would be welcome.

Issue ended up being due to Time Machine / Migration Assistant, resolved via private message