Clipping during DSD playback

Windows 10/Roon 1.6 build 416 64 bit stable
Allo UsBridge --> RME Adi-2 Dac
No upsampling, volume levelling turned on

Hi, I am noticing the clipping indicator lighting up during native dsd playback as per the attached. There’s no conversion to PCM or upsampling or convolution going on here - so why would this be happening?

Hi Nathan,

I don’t know much about this, but check out Headroom Management in this KB article, if you haven’t already and make some adjustments to the Headroom value.

Cheers, Greg

I once had the same problem. But in Headroom Management I changed it from -2 to -3.5 and that resolved my clipping problem in DSD playback.

I now have more insight into what is happening here. Notice how volume levelling is being applied and there is already over 3db reduction?

The so called native dsd processing is causing the clipping. Instead of reducing the volume which should reduce the level and therefore reduce the chance of clipping.

What I think is happening is the “64-bit dsd” stage is really just a very high sample rate and bitrate form of PCM, and there is two conversions going on in order to lower the volume. But there is a problem in the gain staging in the conversion causing clipping.

Clipping does not occur if I untick native dsd processing. In which case it converts to DXD PCM first and then applies volume levelling correctly.

This is a bug in Roon which needs addressing.

In the meantime I’ve also worked out that I am better off converting DSD to DXD as I have digital volume control turned on in my DAC, which means an additional conversion to PCM anyway. So may as well do it once and output in PCM.

Hello @Nathan_Scrivener,

I went ahead and filled a ticket for this, we appreciate your thoroughness with your report.

Additionally, I have sent you PM with a request for some additional information.


1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.